Unable to locate Local disk D drive

I am unable to locate the local disk D partition in devices, I faced the same issue on KDE Neon and now on the Manjaro KDE…
Thanks in advance…


Is the Windows nomenclature of identifying/labeling/ordering unlabeled partitions, so you will not find it that way under linux.
lsblk -sf
from terminal should give you the list, UUID and eventually labels of the attached drives/partitions, then read about mounting them with:
man mount
mount --help

sda2 ext4   1.0         74b41aac-fb6a-4f1d-8475-d960cb97f5fa     82G     9% /
sdb1 vfat   FAT32 SYSTEM
│                       D4E1-CE5D                               204M    20% /boot/efi
sdb3 ntfs         OS    FC24E5E824E5A5BC                                    
sdb4 ntfs         RECOVERY
│                       B8C05189C0514EAE                                    

These are the results of lsblk -sf

When you have located your device you can use this article as guide on how to mount the device on boot.

Right, so:
sda1, sda3, sda4
are unformatted

sda2 is your root partition

sdb1 is where you might have the Windows boot loader and also probably the Grub … as is /boot/efi

sdb3 is where you have the Windows installed i guess, so in that logic Windows saw it as drive C

sdb4 is the recovery partition for you Windows install. Might or not be the D drive … At this point is unmounted the same as your Windows.

If you follow the advice from @linux-aarhus - you might need to know more tho …

1 Like

Okay thank you

I am kinda new to this stuff so plz can you make it simpler or help me out more to mount???

I found that /dev/sda1 is the one I have to mount on boot from KDE Partition Manager whose type is Unknown and Partition Lable as LDM data partition.

Now I’m totally out of ideas how to mount it without loosing any data in it.

From KDE Partition Manager There is an option in properties of /dev/sda1 to change File system from “unformatted” to other file system type but when I’m trying to change it to ext4 it says "Warning: You are about to lose all data on partition ‘/dev/sda1’.

I don’t want to loose any data and mount it on boot.


The only way to change it to ext4 would be to wipe it clean. If you want to keep your data, do not do that.

Here is what I recommend.

I recommend opening Pamac which may be called “Add/Remove Software”

Search for GNOME Disks. If you have it, run it. If not install it and then run it.

In GNOME Disks find the disk you want to mount and click on the partition you want mounted.

Click on the gear icon.

Click Edit Mount Options

Check the box for “Mount at Startup”

Check the Box for “Show in User Interface”

Change the Display name to whatever you want that identifies it for you.

For older pcs/laptops with legacy- bios-MBR,
Is a common problem.
Heres my solution (i discovered it while i was unable to dual boot for a long time😭)

Problem in dual booting [solved] Installation FailedThe installer failed to create partition on disk 'STxxxxxxxxxxxxxxxMBB'

I suspect the device is setup as Dynamic Disk in Windows.

This is something like LVM on Linux and my knowledge on the subject is very little - next to nothing - and certainly not enough to provide any useful help.

My suggestion is to boot into Windows - backup your data to an external storage location - either USB or network share.

Then - still using Windows - convert the disk to basic disk - and format using either exfat or ntfs. Restore your data when you need them.


Yeah, thank you sir…

I’ll try this and post and update if it work…

Tried this, No Edit Mount Point option available on which I can click and go through the process :cry:

Originally you posted this in the wrong category, so no one has asked you to:

Please read this:

and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  1. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
  2. The output to parted --list would be beneficial as I’m leaning towards @linux-aarhus 's diagnosis: you have Microsoft Dynamic disks which are raw partitions from a Linux perspective.


1 Like

If that is true, then the only way is to convert the Partition somehow or backup the data and recreate the partition as basic NTFS.

It possible to read dynamic Windows partition in Linux, but experimental so you don’t want to be a Ginea pig.

Sorry, It looks like you have it set up the way linux-aarhus says and I had not heard of this before.