Unable to install viekk tablet drivers

Tried to install viekk drivers for manjaro. While running make command, i faced the following error:

make -C /lib/modules/5.16.2-1-MANJARO/build M=/home/maxwell/veikk-linux-driver modules
make[1]: *** /lib/modules/5.16.2-1-MANJARO/build: No such file or directory. Stop.
make: *** [Makefile:8: all] Error 2

Hi @maxwell69,

It seems you don’t have the headers installed for kernel 5.16. Install them with:

pamac install linux516-headers

Hope this helps!


Note: I don’t know if this is a dkms module/driver, and if it’s not, you’ll have to reinstall both the module, as well as the headers for every kernel update.


It might be the case that even if you install the linux headers as rightfully suggested above, the run installer you use. might not find them.

Look into AUR as there is also the graphical interface configuration package http://aur.archlinux.org/packages/input-veikk-config
that will also build the package http://aur.archlinux.org/packages/input-veikk-dkms

In other words, after you install the linux headers, if you run
pamac build input-veikk-config

you should end up with a working tablet and configuration UI for it, once you reboot the system.

Heh, I checked the AUR before I replied, I always do, for things like this, and couldn’t find anything…silly pamac.

thank you, this solved the issue

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.