Unable to install snaps using the terminal

when I try to install a software from snapd using the command snap install sublime-text for example, the download begins but when it reaches some point it keeps starting over and over again. the point where it starts over is not dedicated, sometimes it stops and starts over at 39% sometimes it stops and starts over at 99%.

just to mention, I have a bad internet connection I don’t know if that is the problem. but I was using the same connection while using ubuntu and I could install snaps flawlessly.

Have you tried the gui approach with pamac-manager? Is this only happening with sublime-text? Also see Install sublime-text on Manjaro Linux using the Snap Store | Snapcraft

1 Like

pamac-manager works fine as a gui but as you know it doesn’t include all the apps I know, some apps only exists in snapd.

no the problem is not only with sublime-text, it happens with any software I try to download it from snap commands

Pamac-manager is just a gui wrapper for those things. You can either enable snap support from Preference > Third-Party and do it manually following this guide Snap - Manjaro. Both ways work.

1 Like

thank you so much, that worked well <3

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.