Unable to install Manjaro

I’m afraid I have no such line as you can see on this picture.

Press Esc and go to another menu entry. You selected the wrong one.

I wrote driver=vesa into blank field which was made for additional parameters and I’ve got into the system! It seems to be working but I wouldn’t celebrate yet.

As I said previously I had problems with Debian and Ubuntu in the past with drivers. I really hope I won’t have the same problem.

I will report back when the installation process is done, I hope it will be fine. Thank you for help!

1 Like

On Manjaro it is possible to enable amdgpu driver, but that driver doesn’t come with the ISO, yet, AFAIK.
With vesa driver you have low resolution, but you can at least install and then I will guide you how to install the amdgpu driver.

I am unsure what’s happening but the installer is frozen at Unsquash filesystem. 29%. The light on USB flash drive was still continuing blinking for a long time and the mouse was moving with heavy lag.

Now the light is not blinking and mouse is moving freely but everything is frozen. I am unsure if it is just the graphics or the whole system is not responding.

Possible. I haven’t tried Calamares in Vesa mode for a long time.

I would recommend to try the terminal based installer - manajro-architect. I think it is on the ISO, too.

You can also try to launch sudo -E calamares -d from the terminal.

But in both cases I would suggest to reboot with the live USB.

After using terminal to start the installer I have installed Majero on my notebook but now when I press the boot button and then choose to boot in to Majero I am getting stuck at Started TLP system startup/shutdown.

Is it possible to do anything or should I try the Architect installer?

No, no, it was to expect, it is ok.

Now, press “e” at Grub menu, go to the line with “linux” and add a 3 at the end of it. You will boot to command line this way.

Log in with your user name and password.

Then create a file with
sudo nano /etc/X11/mhwd.d/amdgpu-experimental.conf

Section "Device"
	Identifier  "Device0"
	Driver      "amdgpu"
	BusID       "PCI:0:1:0"
EndSection

Run

sudo pacman -Syy
sudo pacman -S amdgpu-experimental mhwd-addon-amdgfx-hwe xf86-video-amdgpu


I have added 3 at the end of where the underline is in the picture but when I tried to boot it still got stuck at the same point.

you need to leave a space like ...544b1 3

I have done all the steps and installed the packages without any errors. Should I rebooted now?

Can you check if you have xf86-video-ati and xf86-video-vesa installed? It would be safer to remove them
pacman -Si xf86-video-ati
pacman -Si xf86-video-vesa

I am not sure but I think I have both of these drivers installed. Unfortunately I have zero knowledge of Pacman and terminal itself. I will take a picture to be sure.

1 Like

No they are not installed, otherwise there would be a line “Installed as depenedednc” or “Explicitely installed”.
You may reboot and hope! :slight_smile:

Something went horribly wrong. I don’t even know what to say haha. But I must admit that the fan is working like a jet engine again

Ok, I thought linux49 doesn’t need that workaround. One moment…

Other possibility might be that your GPUs don’t support AMDGPU driver. But I’m pretty inclined to think that they do.

I don’t think so either because they are not old at all. For some reason I feel like it has something to do with the 2 GPUs I have. Since my BIOS is lacking all the advanced options, which are really hard to enable, I don’t know how to disable one.

Do you have any ideas? Why was I able to boot with Vesa driver?

How could I access the terminal again? I think if I can write this systemctl reboot --firmware-setup I could get into UEFI menu to take a closer look at the settings.

1 Like

Press “e” at Grub menu, go to the end of the line with “linux” and add " 3".

Unfortunately my BIOS is made so that the advanced settings are hidden and I don’t have much control over it. It is very hard and dangerous to mod BIOS so I guess I don’t have any other option but to move back to Windows if we won’t come up with a solution.

Dear eugen-b, do you have any thoughts about this situation? It seems like I can’t run properly any Linux distro.

Forum kindly sponsored by Bytemark