Unable to install Manjaro on NVMe drive

Hi, new Manjaro user - and been a while since I’ve worked with Linux. Attempting to get back into things.

I’ve been trying to install the Gnome build, latest, and it isn’t able to install to my NVMe drive. It’s in a Dell Laptop. I’m at a loss as to what is wrong. I’ve tried installing Windows 10, and the drive was able to be partitioned and installed to, and same with the latest Ubuntu.

I’m not sure where to begin; am I able to get some help?

I have a log from the install - termbin/55c5

Apologies I can’t post the url as a url with the new forum rules.

When I run the failed command, it says “file not found”. GParted didn’t allow me to edit the drive, the disk utility didn’t allow me to edit the partitions. NVMe CLI utils, no drives were visible. But - the drive is visible, and supposedly mounted? I.e., the installer can see there is a 512gb drive.

Welcome. Let’s start with the following tutorials. They will help you learn what to do before getting help:

The first four tutorials will give you what you need to continue. Cheers.

Make sure secure boot as well as fast boot in your BIOS/UEFI is off. If you do not have fast boot, that’s OK.
Make sure anything to do with RAID in the BIOS/UEFI is also disabled.

If the installer cannot recognize the device it may be a VMD device.


One option is to disable VMD in your device firmware.

Another option is to load the kernel vmd module after system is booted but before starting the installer

modprobe vmd

Ah big thanks all.

BIOS wise:

  • Secure Boot is disabled
  • Fastboot, I’ve set to “Thorough”, which will do a complete check
  • SATA mode: Disabled, AHCI and Raid.

That last setting does impact the drive’s visibility.

  • If I set it to disabled, it’s not there. Makes sense.
  • If I set it to AHCI, the drive is visible in the installer as /dev/nvme0n1. I can the size, serial and see partitions are listed as /dev/nvme0n1p1p3. Contents are “Unknown”, partition type is “Unknown”, and the installation fails.
  • If I set it to RAID, the drive is not visible.

I didn’t see any mention of VMD in the bios. Tried modprobe vmd just in case, but that didn’t change anything.

What should my next move be to work this out?
Also, is there anything I can do from Ubuntu to help work it out?

This is what it should be.
But the failure is less positive.

Have you tried formatting the disk using a tool like gparted prior to installation?

PS - also make sure to boot in EFI mode and not in Legacy-Bios.

1 Like

Correct; it is in UEFI boot.

Gparted doesn’t list the drive as an option to select & format. It does appear in the Disks utility.

In terms of formatting, I was able to use Windows 10 installation to format the drive.
I wanted to validate another installation so I did do a full installation of Ubuntu and can boot into that fine. Not the one I wanted to be using though, back in the day I was on ArchLinux.

AHCI should be enabled in a UEFI system.

SATA mode might also need to be enabled for an NVMe; depending on the system. Just make certain it doesn’t switch to IDE mode by disabling it. Your M/B manual likely has that information.

1 Like

Confirmed, no IDE mode.

1 Like