Unable to install linphone-desktop or linphone-desktop-all via AUR

Anyone getting the same error that I’m getting?
It seems linphone-desktop has issues with installing it’s own library.

...
-- Setting install rpath to /usr/lib
CMake Error at CMakeLists.txt:125 (bc_compute_lib_version):
  Unknown CMake command "bc_compute_lib_version".
...
 -> error making: liblinphone

The build issue with linphone-desktop-all is that it can’t seem to validate it’s own package.

...
Validation of source files with sha256sums…
...
linphone-3.12.0.tar.gz ...Failure
...
    fix-qt5_1x.patch ... Success
==> ERROR : One or more files are not valid! 
 -> error downloading sources: linphone-desktop-all
	 context: exit status 1
...

Linphone provides an AppImage you can download from their site, it should work.

1 Like

liblinphone and linphone are flagged out of date since almost a year, while linphone-desktop-all is orphan and flagged out of date since more then a year and not updated in more then 2 years

Try with liblinphone-git and linphone-desktop-git

1 Like

Solved it by downloading the git cloning, reading it’s readme, and the moving OUTPUT to /opt/linphone and creating a launcher on my desktop folder, chown root:root linphone.desktop && chmod 644 linphone.desktop and moving that to /usr/share/applications/

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.