Unable to edit shortcuts

Recently, I mistakenly made the “Esc” key a keyboard shortcut for activating the Notifications widget. However, whenever I go into System Settings->Shortcuts and remove the custom shortcut, the change will not persist, and the shortcut will return after I reboot.

  • Go to System Settings
  • Type shortc in the search bar
  • Click Shortcuts
  • Type esc in the shortcut search bar like in the screenshot below:
  • Does the notification widget show up in that list?


Yes, it does. System Settings->Shortcuts is what I’ve been using to remove the shortcut all this time. I delete the shortcut using System Settings, and every time I do it reappears whenever I reboot.

Have you tried setting another shortcut that you’ll never use like +Ctrl+Alt+Shift+End ???

Does that survive a reboot?

1 Like

If I switch the shortcut to something else, it resets to “Esc” when I reboot.

I think about 6 months ago I had issues with KDE settings - after wasting an hour trying to fix it I did a timeshift (back 24 hours) and it was okay again.

The main issue with doing that is that stuff I watched in PLEX gets marked as unwatched again :wink: not a big deal.

Unfortunately I didn’t have Timeshift set up before this, so I won’t be able to use this solution.

Then create a new user TEST and see if you get the same issue.
If you do, then messing around in and/or renaming hidden folders - like .config and .local can clear the issue.

Lots of possibilities…


This one looks nice.

I appreciate the suggestion. The issue did reproduce on a new user, however modifying kgglobalshortcutsrc didn’t rectify the issue. I’ll continue to search through config folders to see if I can find some other potential files to edit.

No, if a new user has the issue - then there’s something wrong and it’s NOT the config files.

It seems strange that it was YOU (your user) that made the Esc key a keyboard shortcut, and that this shortcut can also exist with a new user…

Are you using a standard, or latte panel?

Also, perhaps remove the notification widget - it should simply appear in the systray.

It seems strange that it was YOU (your user) that made the Esc key a keyboard shortcut, and that this shortcut can also exist with a new user…

To clarify, in order to recreate the problem on a new user, I had to also manually add Esc as a keyboard shortcut on that account, after which point it exhibited the same behavior. The shortcut wasn’t pre-existing in the new account.

Removing the notification widget was actually one of the first things I tried to do. Unfortunately, even if there’s nothing for the shortcut to activate, the shortcut will still impede the use of the Esc key. For instance, if I open the Application Launcher with the Meta key, I can’t close it using Esc. If play a game, Esc will no longer open the pause menu, and so on.

Then start with rename .config to config; log out/in

Renaming .config did indeed rectify the issue. So the problem lies in one of the config files in that folder.

I believe I found the issue. In the .config folder, there is a config file named “plasma-org.kde.plasma.desktop-appletsrc”. In that file, I found the lines


Removing this entry , then logging out/in, appears to have solved the issue. However, that still leaves me with the question of how did this entry make it into this config file. If one of the more knowledgeable posters on here could elucidate me as to likely possibilities, I would appreciate it.

1 Like

Wow, Great job!

Now this should be a lesson in using terminal… Often I think after the fact ‘we didn’t do this the Linux way…’.

We already know we wanted to look for ‘Esc’ and/or ‘Shortcut’.

Maybe we should have opened a terminal and used grep (better still, the rust equivalent ‘ripgrep’ which is rg).

So let’s have a bash at this…

rg -w Esc ~/.config/k* (ripgrep the word ‘Esc’ in any kind of ‘k…’ folder in .config)

This is cool, though it does pull in some heavy spam from svg files…

Maybe rg -w Esc ~/.config/k* would be nicer…

Time to go to youtube and watch some tutorials about grepping.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.