Unable to download extensions in code

Hello everyone ,
I have installed code version:1.58.0 & I am unable to download extensions I get this error message.
“We cannot connect to the Extensions Marketplace at this time, please try again later.”

1 Like

There are a few github issues that address your problem and this doesn’t seem to be Manjaro-specific.

Can't connect to the extensions Marketplace · Issue #97484 · microsoft/vscode · GitHub (most solutions)

1 Like

So , this means I will get no solution here😶

Yes because this issue is VSCode related and not Manjaro-related. I have read all the issues myself and there are various solutions, find one that works for you.


Issue is because of open vsx CORS request as mentioned here Searching the extension marketplace fails with CORS error · Issue #128583 · microsoft/vscode · GitHub
Solution: There is temporary workaround:

in the file ~/.vscode-oss/argv.json
add the line: "enable-browser-code-loading": false

Reference: [1.58] Extension marketplace not working · Issue #746 · VSCodium/vscodium · GitHub


I had the same problem.
I’ve uninstalled vscode and reinstall it following this tutorial

1 Like

Actually I reinstalled vscode-bin and the problem was only with code the linux version of vscode.I’ll update if this happens again.:grinning_face_with_smiling_eyes:


I had installed code from pamac, and I was facing the same problem. I uninstalled the code from pamac, and then used snap to install VSCode, and now it’s working as intended. If anyone is facing the same problem, you might want to try snap for installing VSCode.

1 Like

I am also unable to install extensions for vscode via editor. For now I am installing them via terminal, this can be done with:

code --install-extension extensions...

For instance, to install the python extension, I run:

code --install-extension ms-python.python

I have the same issue. But it was working several days ago when I installed python extension.
Reinstalling doesnt help.

@armujahid Works when I put it one line before crash reporter id in the brackets(doesnt work if put after crash id.) Make sure to put comma at the end(after false). Thanks

Hello, I do face the same problem when trying to install a extension from the market place.
I added the text line in argv.json as mentioned before the crash-id line without success. I also tried to install via CL what ended up with a DEP00005 error report related to any buffer/security problem.

I also installed the AUR package for testing but same result.

Anyone here who knows how to fix the problem? Reading related other articles about “marketplace connection problems” ended up in confusing me even more. So, an easy solution is appreciated.

Same problem here, are you having issues with logging onto vs code account too?

Mine is stuck on loading.

Worked for me. I just inserted the quoted line.


I found a solution. For me was to follow exactly these steps (I already had SNAP support enabled and had a clean Manjaro installation, for some reason it was not working):

sudo pacman -S snapd
sudo systemctl enable --now snapd.socket
sudo ln -s /var/lib/snapd/snap /snap
sudo snap install code --classic

Now let me tell you something… I tried to install visual code with Snap in the Add / remove Software… and it was displaying errors. So I follow these previous commands and it work!

Here is the link from I tool the code lines:
snapcraft . io /install/ code/ manjaro

I used to had the same problem on Manjaro 5.10.59 after installing Code OSS from the AUR.
I found a easy solution on StackOverflow, I can’t attach the link so I’m gonna tell what I did…
All I did was paste this code:

"extensionsGallery": {
    "serviceUrl": "https://marketplace.visualstudio.com/_apis/public/gallery",
    "cacheUrl": "https://vscode.blob.core.windows.net/gallery/index",
    "itemUrl": "https://marketplace.visualstudio.com/items"

on the “product.json” file which is located somewhere on your file system (/usr/share/code… or anywhere) In my case, the file was located on /usr/lib/code

So, all you need to do is search into “product.json” file where the “extensionsGallery” is being declared and replace all that code with the new one. You want to ensure you are not declaring “extensionsGallery” twice or Code even not will be able to run.

Hopefully it can help.


There is a convinient AUR package for that: AUR (en) - code-marketplace
It will keep up with package updates via pacman hook.


Worked for me.

Thank you, this worked form me!

Thanks it worked for me