Unable to download anything from AUR


#1

Earlier today, I was attempting to install some browser plugins for Vivaldi, a browser I was trying out. The install failed so I tried to install something else. This time, I was greeted by an error message stating that the package could not be found in Yaourt. I thought it was a fluke at first, but every package does this.

Here is an example:

[kacie@manjaro ~]$ yaourt epsxe
1 aur/bin32-epsxe 2.0.5-5 (0) (0.00)
Enhanced PSX emulator (32-bit)
2 aur/epsxe 2.0.5-22 [installed: 2.0.5-19] (203) (1.42)
Enhanced PSX emulator (64-bit)
3 aur/epsxe-plugin-gpu-mesagl 1.78-4 (91) (0.34)
Accelerated MesaGL plugin
4 aur/epsxe-plugin-gpu-soft 1.18-2 (31) (0.29)
Software GPU Plugin
5 aur/epsxe-plugin-gpu-xgl2 2.9-6 (100) (0.20)
Linux port of the OpenGL2 plugin
6 aur/epsxe-plugin-padjoy 0.82-3 (76) (0.20)
Joy-device plugin
7 aur/epsxe-plugin-spu-alsa 1.9-5 (101) (1.16)
OSS/Alsa SPU plugin
8 aur/epsxe-plugin-spu-eternal 1.41-2 (7) (0.00)
Epsxe Eternal SPU plugin
==> Enter n° of packages to be installed (e.g., 1 2 3 or 1-3)
==> ---------------------------------------------------------
==> 2

==> Downloading epsxe PKGBUILD from AUR…
(23) Failed writing body
==> ERROR: epsxe not found in AUR.
[kacie@manjaro ~]$

Also when using Yaourt to find something that has a lot of package results, everything but the most recent screen becomes blackened out as if there was no text at all.

I am unsure of what the issue might be. Is there anything that I can do to fix this?


#2

You’ve enabled the AUR (installed base-devel) and installed stuff via Yaourt before, right?


#3

Yes I have been able to install with Yaourt in the past just fine. The issue began when I tried to install this package:

5 aur/vivaldi-ffmpeg-codecs 61.0.3163.91-1 (82) (3.25)
additional support for proprietary codecs for vivaldi


#4

sudo pacman-mirrors -f 5 && sudo pacman -Syyu
yaourt -Syua
yaourt -C [#this will check for pacnew and pacsaves … just take a look]


#5

So do I just enter in yaourt -C in the terminal?


#6

This is what I get:

[kacie@manjaro ~]$ sudo pacman-mirrors -f 5 && sudo pacman -Syyu
[sudo] password for kacie:
.: INFO Downloading mirrors from repo.manjaro.org
.: INFO: Querying mirrors - This may take some time
0.470 Germany : 00:11: https://repo.stdout.net/manjaro/
0.059 United_States : 09:32: http://mirror.solarvps.com/manjaro/
0.593 Belgium : 03:30: https://manjaro.cu.be/
0.720 Bulgaria : 00:40: https://manjaro.ipacct.com/manjaro/
0.697 Australia : 00:29: http://manjaro.melbourneitmirror.net/
.: INFO Writing mirror list
United_States : http://mirror.solarvps.com/manjaro/stable
Germany : https://repo.stdout.net/manjaro/stable
Belgium : https://manjaro.cu.be/stable
Australia : http://manjaro.melbourneitmirror.net/stable
Bulgaria : https://manjaro.ipacct.com/manjaro/stable
.: INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
:: Synchronizing package databases…
core 137.1 KiB 1652K/s 00:00 [######################] 100%
extra 1763.5 KiB 4.53M/s 00:00 [######################] 100%
community 4.4 MiB 6.62M/s 00:01 [######################] 100%
multilib 179.2 KiB 6.73M/s 00:00 [######################] 100%
:: Starting full system upgrade…
there is nothing to do
[kacie@manjaro ~]$

[kacie@manjaro ~]$ yaourt -Syua
[sudo] password for kacie:
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
canon-pixma-mg2200-complete : Orphan
castawesome : Orphan
gstreamer0.10-ffmpeg : Orphan
lib32-libtinfo : Orphan
Foreign packages: / 77 / 77

==> Package upgrade only (new release):
aur/epsxe 2.0.5-19 19 -> 22
aur/goocanvas1 1.0.0-4 4 -> 5
aur/qtwebkit 2.3.4-5 5 -> 6
aur/ttf-oxygen 1:5.4.3-3 3 -> 4

==> Software upgrade (new version) :
aur/gzdoom 3.2.0-1 -> 3.2.1-1
aur/libc++ 4.0.1-1 -> 5.0.0-1
aur/libc++abi 4.0.1-1 -> 5.0.0-1
aur/libc++experimental 4.0.1-1 -> 5.0.0-1
aur/lwks 12.6.0-1 -> 14.0.0-5

==> Continue upgrade ? [Y/n]
==> [V]iew package detail [M]anually select packages
==> --------------

[kacie@manjaro ~]$ yaourt -C
[sudo] password for kacie:
0 .pacorig found
12 .pacnew found
0 .pacsave found
0 files are orphans

1 02/13/2017 07:31:51 AM /etc/security/pwquality.conf.pacnew
2 06/21/2017 10:44:00 AM /etc/group.pacnew
3 06/21/2017 10:44:00 AM /etc/gshadow.pacnew
4 06/21/2017 10:44:00 AM /etc/nsswitch.conf.pacnew
5 06/21/2017 10:44:00 AM /etc/passwd.pacnew
6 06/21/2017 10:44:00 AM /etc/shadow.pacnew
7 07/15/2017 06:00:08 AM /etc/pacman.conf.pacnew
8 09/19/2017 03:42:03 AM /etc/pulse/daemon.conf.pacnew
9 10/06/2017 03:27:55 PM /etc/mkinitcpio.conf.pacnew
10 10/09/2017 06:16:14 AM /etc/locale.gen.pacnew
11 10/19/2017 12:03:02 PM /etc/drirc.pacnew
12 10/26/2017 04:03:37 AM /etc/pacman-mirrors.conf.pacnew

==> Enter n° :


#7

I just attempted to install a small game using Octopi, the frontend for pacman/yaourt. And while using the terminal caused it to fail, installing it directly in Octopi yields success and the game runs fine.

Edit: I attempted to install Midori with Yaourt as it was not in the AUR. While it does install, it did bring up two error messages. Sadly due to the blacking out thing, I cannot show the entire message.

error: could not copy tempfile to /tmp/alpm_PQpdJg/.INSTALL (No space left on device)

This one is odd as I cleared out my temp stuff and have about 13 GB remaining on the partition reserved for installing things.

The other message is this:

error: file owned by ‘libtinfo’ and ‘ncurses’: 'usr/lib/libtinfo.so’
error: file owned by ‘libtinfo’ and ‘ncurses’: ‘usr/lib/libtinfo.so.6’

These files gave me trouble before, preventing me from upgrading my machine. I had these files removed and reinstalled with the upgrade.


#8

The Manjaro /tmp is actually in RAM, not on the hard drive. I believe half of your RAM is allowed for /tmp use. So you can run out of space there, especially if you’re trying to build a big AUR package (which builds in /tmp).

A reboot should clean out your /tmp. But to avoid running out of space when building from AUR, you can also tell yaourt to use another directory (on your hard drive) instead of /tmp. Such as this: yaourt -S [package] --tmp /home/tmp

p.s. Midori is in the Manjaro repositories.


#9

Ah okay, I’ll try rebooting later and see if that works.

And yeah I know I don’t need to use Yaourt for Midori. I was trying to see if Yaourt couldn’t install anything at all or if it was just the AUR portions that couldn’t.


#10

Okay so it appears that rebooting did work and Yaourt worked fine. At least for a little while. Upon trying to install this again:

5 aur/vivaldi-ffmpeg-codecs 61.0.3163.91-1 (82) (3.25)
additional support for proprietary codecs for vivaldi

The same issues reoccurred. There was a bunch of “write failed” messages that popped up and Yaourt is back to being unable to install anything from AUR. I wonder if it’s because that thing I tried to install is just way too large.


#11

Instead of yaourt, you can try pacaur. It’s in the repos.


#12

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.