Unable to create bootable flash media

Hi, I downloaded the Manjaro gnome minimal image from the official site, but I have been unable to create a bootable flash for it.

When I tried using Rufus, it formats as a DVD and my laptop does not recognize it upon boot.

I tried using unetbootin too, but when I tried to boot from it, I get an image fail to authenticate error.

I’ve been on it for the past few days and I’m getting frustrated. I’d really appreciate any help I can get. Thanks.


You have to enable DD mode. See Burn an ISO File - Manjaro

That will not work … Try etcher or maybe better go with Download . Ventoy as will let you copy the ISO directly and still use that USB Stick for data …

1 Like

Won’t work - and booting from optical device is very - very slow.

Won’t work

The only method viable for writing a Manjaro ISO file is the dd method.

Rufus and Etcher can do this - as pointed out by @bogdancovaciu - with Rufus must not select any option but the dd method.

Ventoy is a little different - the ventoy preparation tool creates a bootable USB with one big empty partition and a 4M efi partition at the end and you must manually copy the iso file onto the empty space of the stick - the upside to this is you can have as many iso-files as your stick can hold and each one is bootable from the ventoy bootmenu.