Unable to create and open MS Office documents

ms-office

#1

I have some experience with Ubuntu/Debian and Fedora. I first tried Manjaro in a VM inside Ubuntu and loved it, so I turned it my primary OS. One thing I liked so much when testing Manjaro in a VM was the ms-office application. But now that Manjaro is my primary OS, it doesn’t work. This is the problem:

When I open an application (say, ms-word, but the same happens with the other MS applications) and try to open a new document, it says “unable to create new documents” (screenshot attached). But it works fine in the browser. Any idea why is this happening?


#2

I just tested this from the KDE version and after signing in to my Microsoft account I was able to see and create documents. My screen does not look like yours however. Is that screenshot what you see when you are using the menu entry or in your web browser? Not sure if this helps but I noticed the difference.


#3

I just tested it on xfce and face the same issue. One way to overcome it is with a dirty trick like uploading a docx file and having it open “automatically” at finish. It will then open the file properly and you can work on it.

To be honest, I’m not too fond about word online anyway. It seems to miss a lot of features.

This is off topic but might I suggest WPS office? It’s a shameless office clone but works perfect, supports 99.99% of native windows Word styling and layouts and produces 99.99% compatible documents that can be used on windows Word.

Only thing you need to do is to copy all ttf fonts from a windows with office box and install them in manjaro so it’s perfect with WPS.


#4

the libreoffice vs onlyoffice vs wps vs msonline thing is a long and addled topic that has surprisingly been somewhat missing on the forums. I’m not yet sure where I stand besides encouraging folks to use what works.


#5

Thankfully I’m out of the workforce and hopefully never have to use another proprietary document format for the rest of my days.


#6

It’s from the menu entry. Have no problems in the browser. I forgot to say that my first try with Manjaro in a VM was with Manjaro KDE, and the ms-office worked fine. The screenshot is the xfce ms-office. Perhaps is a DE problem?


#7

Never heard of WPS. This is the very first time I’m forced to use ms office. Back in my college days I was perfect using libre/openoffice and LaTeX.

Thanks for the advice. I’ll try using WPS. Just a comment on ms-office. If it doesn’t work on xfce, why to bother?


#8

I envy you!


#9

Then the issue is most likely with JAK which is the wrapper around the webpages running ms office online.


#10

Try it. I never heard of it until a fellow sys admin told me he used it for elementary school pcs because he had run out of Microsoft licenses… I was reluctant at first but after I installed it and added all office fonts… OMG… 1:1 compatibility in 99% of all documents I have ever used. Only 1 document (excel) wouldn’t open. It had 360 tabs so I guess that was the problem (but I could open it in libreoffice, so who cares, right?)