Unable to Connect to WiFi connection with Manjaro

wifi
#1

Hey Manjaro forums, I'm a linux user of a few years now (tried debian, xubuntu, mint) and decided to give manjaro a try on my brand new PC. I managed to burn the iso on a bootable usb and it worked perfectly, however there is an issue when trying to install it on my solid state drive.

The problem is that I can't connect to any wifi, so I can't install it yet. In the networks list on the sidebar neither of the house's wifi signals appear (nor the long list of neighbourhood signals we pick up for that matter), but it's completely blank. My laptop and phone can connect in this area of the house just fine, and I've never had this issue with any other linux installation. What could be causing this? Could it be a hardware problem? I assumed the motherboard (gigabyte b450m) came with a wifi card pre-installed like many modern motherboards (or so I've been told), but I could be wrong. If it is a hardware problem, apologies for the wasted time/thread.

#2

Hi,
What does this return?

inxi -Nnz
#3

I searched online for the motherboard "gigabyte b450m" that you said you owned. You did not even give the full model number of your mobo. I found 3 different mobo's starting with that model number referenced online. None of those models include wifi onboard. Surely you could have done this online search yourself instead on posting a help thread on the forum.

Just for future reference most desktop motherboards do not include onboard wifi. Laptops almost always do, desktops not so much.

In the future when you open a hardware support thread be sure to include an output of your specifications on your initial post as requested below.

The best all around command output to include is:

inxi -Fxxxz

If you want WiFi you'll have to buy an adapter with good Linux driver support. I would not waste money on a wifi adapter for a desktop though. I would buy a powerline adapter to give you much faster internet through your LAN connection.

#4

The best way is to install with cable or image like dvd or so. That is a fact for all distributions. If you dont have a network port then buy a USB networkcard. Sorry for my bad english :sweat_smile:

#5

A USB to ethernet adapter is not needed as that mobo includes a very fast LAN adapter.

Usually when someone is trying to setup wifi for a desktop it is because they are in an awkward location to run a lan cable. A powerline adapter solves that issue because it simply uses your houses pre-existing electrical wiring to create the connection. Powerline adapters are a very good option, as the technology has matured and it is now far superior to wifi.

1 Like
#7

So I put in inxi -nnz and got:
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp4s0 state: down mac:

inxi -Fxxz gives me a massive output I can't retype here lest I spend an hour on it but it goes give me the overall specs for my computer (graphics, CPU, etc.). It also gives me network, which I assume is important, so I'll retype it here:
Network:
Device-1: Realktek RTL8111/8168.8411 PCI Express Gigabit Ethernet
Vendor: Gigabyte driver: r8169 v: kernel port: f0000 bus ID: 04: 00.0
chip ID: 10ec:8168
IF: enp4s0 state: down mac:

I hope that information is useful. As for the powerline adaptor, I assume it works in a similar manner to a wifi adaptor (i.e. lets the machine connect to my home's LAN/wifi) but is more powerful overall? Would a wifi adapter or network card also work fine for connecting to a home wifi connection?

And if the motherboard already has a LAN adapter, how come it's not connecting to the wi-fi?

#8

Of course ..PE!! I forget. :hugs: I've got no experience with this technology and linux. But good to know that is working....

#9

"Inxi" detect only your networkcard/LAN adapter but not a wifi-card. Are you sure you installed a wificard? A LAN Adapter is not a wifi-card! :wink: The other problem is that your networkcard is not connected to the network. So you dont have internet.
Power over Ethernet is a funny technology but also vulnerable for errors. I've got no experience with this and linux. Wifi is okay and a wifi-adapter is cheaper than a Power over Ethernet-Adapter. But i cant tell you which still working with linux. The biggest problem of wifi is the security. You must use a WPA2 wifi-card! WPA2 is a safty standard and is relatively safe if you change the password regulary. WPA2 encoding the data which is sending over wifi but not the data in the internet. I hope you understand! :joy: Search for WPA2 in wikipedia. That is the best idea.
Ach! You need a wifi-router for wifi. But i think you know it.:grin:

#10

If you have no internet connection currently you can try USB phone tethering to upload the required diagnostic outputs.

Which kernel and desktop are you using?

If you can get a connection via phone tethering try installing different kernel versions through Manjaro Settings Manager.

Please post the output of the following command:

grep -r "blacklist\|install\|options"  /etc/modprobe.d/ /etc/modules-load.d/ /usr/lib/modprobe.d/ 

You seem very confused as to how network connections work. LAN connections are wired via a cable to the network router. Do you have the proper cat5 or cat6 cable connected from your router to your LAN network interface card on the back of your computer?

Reboot both your router and computer.

Test from different live disks to see if you can get a connection.

Have you tried different network cables, (min cat5e, preferably cat6e) , and different ports on the router.

Ensure your BIOS is up to date.

Consider resetting your bios back to the factory default settings.

Ensure your router firmware is up to date.

Consider resetting your router back to the factory default settings.

Test with a different router if possible.

#11

And this is why I gave you the short Network only version :wink:

#12

That's what phone tethering is for, but at last there's no screencaps. :wink:

#13

LAN is "local area network" and signifies a wired connection, typically Ethernet.

WLAN is "wireless local area network" and signifies a wireless connection.

An Ethernet network card won't let you connect to wi-fi.

It sounds like you should buy a book or two on computer basics. Books are a far more efficient information/knowledge delivery mechanism than a web forum.

1 Like
#14

If you have the LAN cable connected from your computer to your router now you can try running these commands:

sudo modprobe -r r8169
sudo modprobe -r r8168
sudo modprobe r8169
sudo ip link set enp4s0 up
sudo systemctl restart NetworkManager