Unable to connect to the Internet

That looks good. Let’s check your available devices: ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp34s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 00:d8:61:fc:b7:72 brd ff:ff:ff:ff:ff:ff
[mike@mbbrady ~]$ 

Do you have “fast boot” enabled, by chance? If you are not sure, it might be good to check and disable it before we continue troubleshooting.

No, fast boot was/is disabled.

Okay, a few other things that might help us identify where the problem is.

ip route should show the IP address of your gateway (your router). If it does not, there’s the problem.

You should be getting an IP address assigned from your router through DHCP. Run ip address, and your device’s IP address should be listed next to the device NetworkManager listed above (enp34s0).

Try to ping your router using the IP address from the ip route command above. If the IP address is for example, the ping command would be ping If the ping is successful, it will keep going until you press Ctrl+C.

Try to ping an external IP address. A commonly used IP address is because it is easy to remember.

Try to ping a website with its FQDN, for example ping forum.manjaro.org.

A couple things you could try is connect directly to the router and see if that solves the issue.Also you could update to a newer LTS kernel like 5.10 or 5.15.

ping forum.manjaro.org failed. I was able to ping my router IP address and IP address

I recall now that I may have made a change to my BIOS when I was trying to remote access computers on my network using NoMachine. I was also creating VMs in Windows at the time. Enabling Hyper-V may have been the BIOS change, which I’m recall from memory a month back, so not 100% sure. Hyper-V is currently enabled. Would that affect Internet connection in Manjaro?

I do not know the answer to that, but if so that would be something I have never heard of.

It might be your DNS assignments just need to be adjusted. I have seen cases where Windows is able to work around bad nameserver assignments from the gateway (perhaps Windows has baked-in DNS alternatives), but Linux tends to do as it is told and if you ask it to use a bad DNS server it will just fail.

What is the output of cat /etc/resolv.conf?

[mike@mbbrady ~]$ cat /etc/resolv.conf

Generated by NordVPN

nameserver[mike@mbbrady ~]$

That may be the crux of the issue right there. Although I do get a ping back from the first address, I cannot get a response from

ping PING ( 56(84) bytes of data. ^C --- ping statistics --- 272 packets transmitted, 0 received, 100% packet loss, time 277535ms

I am guessing those IP addresses are assigned by your ISP. ISPs are notorious for setting up their own nameservers so they have an easy way to collect information about their subscribers browsing habits. Often times these nameservers do not function well or are broken.

The best fix would be to log in to your router’s admin portal and change your DNS servers to something better. This change would trickle down to NetworkManager automatically and would result in the least amount of fuss. Logging in to your routers admin portal is different for every device, but typically it isn’t hard to find some instructions by doing a web search for the model of your router.

Note: some routers do not allow changing DNS settings. Typically this would only be the case if you rent a device from your ISP and that is how they have configured it.

Another option is to edit your /etc/resolv.conf file to include the DNS servers you would like. You can use nano or whatever editor you are comfortable with to make the edit. The tricky thing is that NetworkManager will automatically update this file with whatever settings it gets from the gateway on your next boot (that is why it is ideal if you can change the DNS server settings in the router itself). You can work around this if you need to by making /etc/resolv.conf write protected by assigning the immutable file attribute to it. To do this, as root run:

chattr +i /etc/resolv.conf

Good DNS servers to choose are OpenDNS: and A lot of folks use the Google nameservers because they are fast and reliable (and easy to remember): and

Again, my guess is Windows has a backup nameserver baked in and is able to work around this on its own. Try changing the nameserver and see if your internet connection is restored.

1 Like

Do I use and for start and end IP address, respectively? When I try to save I get an error: “IP Addresses: Start IP address is greater than End IP address”

Is that an error message you are getting from the admin portal on your router? Is it possible to post a screenshot of what you are seeing?

NordVPN on Manjaro

Due to the way NordVPN work the system nameserver does not get restored correctly - which is the root cause of your issue.

The long version

The short version - be sure you read above topic

sudo systemctl enable --now systemd-resolved
sudo mv /etc/resolv.conf /etc/resolv.conf.bak
sudo ln -s /run/systemd/resolve/stub-resolv.conf /etc/resolv.conf
sudo systemctl restart NetworkManager
resolvectl status

:point_up_2: My mistake, I did not notice that. Looks like a good tip!

I am connected to the Internet on Manjaro - thanks so much everyone.

I had to reboot to move the .conf file.

In Windows, I successfully changed my DNS server name to OpenDNS (thanks BluishHumility). However, the server name was not changed in Manjaro.

           Protocols: +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported
    resolv.conf mode: stub
  Current DNS Server: 2600:4040:2017:6c00::1
         DNS Servers: 2600:4040:2017:6c00::1
Fallback DNS Servers:
                      2620:fe::10#dns.quad9.net 2001:4860:4860::8888#dns.google
          DNS Domain: myfiosgateway.com

Link 2 (enp34s0)
    Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
         Protocols: +DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server:
       DNS Servers: 2600:4040:2017:6c00::1
        DNS Domain: myfiosgateway.com

What happens in Windows stays in Windows.

When you connect using your NordVPN account the resolver will change - and when you disconnect the resolver will be reset to your router.

If you want your system to use other nameservers than your ISP provided (through the router) you will have to create a drop-in config for the resolver to use. Just like it is possible to change the fallback servers.


sudo mkdir -p /etc/systemd/resolved.conf.d
sudo touch /etc/systemd/resolved.conf.d/dns_servers.conf

Then edit the file (eg. using the micro or nano editor) and insert the following content - adjust as necessary

DNS=nameserver_ip_1 nameserver_ip_2

Read more in the Arch Wiki systemd-resolved - ArchWiki

I was mistakenly looking at DHCP in my router.

I know this is beyond the scope of the original question, but maybe helpful for others… I created the conf using OpenDNS IP Addresses:


Then I cleared the browser cache and flushed DNS cache using:

$ sudo systemd-resolve --flush-caches
$ sudo resolvectl flush-caches

After reboot:

[mike@mbbrady ~]$ resolvectl status
           Protocols: +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported
    resolv.conf mode: stub
  Current DNS Server:
         DNS Servers:
Fallback DNS Servers:
                      2620:fe::9#dns.quad9.net 2001:4860:4860::8888#dns.google
          DNS Domain: ~.

Link 2 (enp34s0)
    Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
         Protocols: +DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server:
       DNS Servers: 2600:4040:2017:6c00::1
        DNS Domain: myfiosgateway.com

I used:

instead of:

ups - sorry - typo - I meant -p :man_facepalming:

Apart from assigning a static IP/24 or changing your routers DNS configuration to use specific servers - there is no way of avoiding the DHCP assigned DNS from the router.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.