Unable To Change Ownership For USB Mountpoint

I have created a dedicated mountpoint for a flashdrive I use to carry files between home and the office. Unfortunately, the mountpoint is owned by root and I do not have write permissions. I have to enter Ranger as admin in order to transfer files from the desktop to the usb. I tried changing the ownership, but am told the operation isn’t allowed.

    [jpbaiocchi@bruiser ~]$ sudo chown jpbaiocchi:jpbaiocchi /mnt/usb
    [sudo] password for jpbaiocchi: 
    chown: changing ownership of '/mnt/usb': Operation not permitted
    [jpbaiocchi@bruiser ~]$

This worked for me before here. The only thing I can think of is the USB uses a different FS; fat32 to be specific.

sudo mount -t vfat /dev/sdXY /mnt/usb -o rw,umask=000
Where X is the drive and Y is the number of partition.

Usually on each DE i used, when mounting trough file manager i get the proper way to write on fat32 … and it mounts under /run/media/myName/

I am currently unable to access the computer I was having this problem with for the next week. So I am unable to test out offered solutions. How long until this thread locks? I know the forum locks certain threads after a set time period.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.