Unable to boot, or run pacman/pamac after latest update

Partial update state.
You should run from TTY:
sudo pacman-mirrors -f5 && sudo pacman -Syyu

1 Like

Already tried this.
pacman-mirrors works but “sudo pacman -Syyu” again gives “error loading shared libraries: libunistring.so.2”
I can chroot and access tty but error remains same

Could you please provide the output of

pacman -Qm

Should this be understood as you cannot login using TTY?

This is from a live boot?

1 Like

Also post

ldd /usr/bin/pacman

It’s either a partial upgrade or some AUR libs.

pacamn -Qm shows same error “error while loading shared libraries: libunistring.so.2”

And no, its not live boot, its on my manjaro installation

ldd /usr/bin/pacman

  linux-vdso.so.1 (0x00007ffc70db8000)
        libalpm.so.13 => /usr/lib/libalpm.so.13 (0x00007fc5f86a0000)
        libarchive.so.13 => /usr/lib/libarchive.so.13 (0x00007fc5f85d9000)
        libc.so.6 => /usr/lib/libc.so.6 (0x00007fc5f83f2000)
        libcrypto.so.3 => /usr/lib/libcrypto.so.3 (0x00007fc5f7fa7000)
        libcurl.so.4 => /usr/lib/libcurl.so.4 (0x00007fc5f7eff000)
        libgpgme.so.11 => /usr/lib/libgpgme.so.11 (0x00007fc5f7ead000)
        libacl.so.1 => /usr/lib/libacl.so.1 (0x00007fc5f7ea1000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007fc5f7e76000)
        liblzma.so.5 => /usr/lib/liblzma.so.5 (0x00007fc5f7e4c000)
        libzstd.so.1 => /usr/lib/libzstd.so.1 (0x00007fc5f7da3000)
        liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007fc5f7d81000)
        libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007fc5f7d6e000)
        libz.so.1 => /usr/lib/libz.so.1 (0x00007fc5f7d52000)
        /lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007fc5f8743000)
        libnghttp2.so.14 => /usr/lib/libnghttp2.so.14 (0x00007fc5f7d26000)
        libidn2.so.0 => /usr/lib/libidn2.so.0 (0x00007fc5f7d07000)
        libssh2.so.1 => /usr/lib/libssh2.so.1 (0x00007fc5f7cc5000)
        libpsl.so.5 => /usr/lib/libpsl.so.5 (0x00007fc5f7cb1000)
        libssl.so.3 => /usr/lib/libssl.so.3 (0x00007fc5f7c11000)
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007fc5f7bbb000)
        libbrotlidec.so.1 => /usr/lib/libbrotlidec.so.1 (0x00007fc5f7bad000)
        libassuan.so.0 => /usr/lib/libassuan.so.0 (0x00007fc5f7b98000)
        libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007fc5f7b72000)
        libunistring.so.2 => not found
        libunistring.so.5 => /usr/lib/libunistring.so.5 (0x00007fc5f79b6000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007fc5f78de000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007fc5f78b0000)
        libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x00007fc5f78aa000)
        libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007fc5f789c000)
        libkeyutils.so.1 => /usr/lib/libkeyutils.so.1 (0x00007fc5f7895000)
        libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007fc5f7881000)
        libbrotlicommon.so.1 => /usr/lib/libbrotlicommon.so.1 (0x00007fc5f785e000)

I asked because of your explicit mention of chroot - which is only used from live ISO.

Since pacman refuses to work - try pamac

pamac list -m

and if pamac refuses to work as it uses libalpm - we will have to consult the birds


pamac list -m
pamac: error while loading shared libraries: libunistring.so.2: cannot open shared object file: No such file or directory

The following is a dirty hack - you may - temporarily - try to work around the issue by symlinking

ln -s /usr/lib/libunistring.so.5 /usr/lib/libunistring.so.2

Then return to listing foreign packages

pacman -Qm

You need to fix the underlying issue - which is most likely caused by a custom package.

There is no guarantee this wil work and may create another issue - in any case - you must remove the symlink afterwards

rm  /usr/lib/libunistring.so.2

pacman started working after this. But now plasmashell is not starting
“qt.qpa.xcb: could not connect to display”

Stay in TTY - as I said - you need to / must fix the underlying issue before you boot into a desktop.

You must remove whichever custom package listed by pacman -Qm then run a full system sync

sudo pacman -Rd $(pacman -Qqm)
sudo pacman -Syu

You can rebuild your custom packages later

Needy pacman. :stuck_out_tongue:

Then you are lucky. Update everything then - to me this still looks like a partial upgrade and

pacman -Q libunistring

probably shows v1.1-1 or even v1.0.

i must say that after your previous fix i rebooted. plasma(x11)was not booting but plasma(wayland) worked.
so currently i will stick to booting into wayland.

pacman -Q libunistring                                                                                                                                     1 ↵   02:09 PM   
libunistring 1.1-2

I said temporary - that means you must fix the underlying issue - otherwise you will get weird issues later on - the symlink is temporary - a bandaid - so fix the underlying issue.

Everything else is unsupported

1 Like

i had this error of plasma(x11) not booting. i have custom theme instaled in lightdm. i will look into it.

Mkay… then it’s some other package. You still haven’t gave any info on full update or commands @linux-aarhus asked for. I’m not going to pry info out of you anymore.

Huh, what?

i think i have given any info asked by @linux-aarhus.

I am using KDE. plasmashell is not opening in x11 session but booting normally in wayland session.

due to some issue I have replaced the default SDDM with lightdm as login manager.

Please fix the underlying issue and remove the bandaid symlink mentioned above - this bandaid is how xy problem is created.

1 Like

yep. Thankyou for your quick fix. i needed my pc for some urgent work. Once i am done , i will investigate the issue.( and also post here if I find the real problem)