Unable to boot Live USB since NVMe installed

Been trying to figure this out since January.
I dualboot windows10/Manjaro on a sata ssd. My wife got me a samsung 500gb nvme drive for christmas so I installed that and windows10 and I have been unable to install Manjaro since.
I gave up for a few weeks and 4 days ago decided to try again with the new build manjaro-xfce-18.0.3-stable-x86_64.iso
the iso sha-1 match fine and I have created a usb with rufus and etcher and neither will get me past the boot screen.
I have checked secureboot disabled, fastboot is disabled and windows power settings fastboot off also.
Now the usb boot as far as the Manjaro boot menu
I leave everything at default and choose the boot manjaro option and get some lines of text
[OK] Started … and so on but it stops at
[ OK ] Listening on Load/Save RF itch Status /dev/rf
the screen then goes blank and nothing


Now I was able to install and dual boot fine up to installing this nvme drive.
My PC is a self build
Asus Prime X370 Pro
Ryzen 5 1600
Asus Strix RX470
16Gb Corsair 3000 DDR4
500Gb Nvme
120Gb SSD
2x 1Tb HDD
1x500gb HDD
I have searched and searched and just cannot figure out why this is not booting the OS and I miss Manjaro
Let me know if any more info is required and the commands to get them.

There is a problem with the firmware in Samsung NVME drives when it comes to Linux. The kernel will sometimes try to put the drive into a power state that it does not support. It will cause system hangs, random errors, and sometimes lost data. I found that this happens with live media as well. Adding the following kernel parameter at boot corrects this issue.

nvme_core.default_ps_max_latency_us=5500

I hope this helps.

2 Likes

Thanks @linesma
Assuming I enter that parameter by selecting the paper icon below the boot manjaro option and typing the line is the correct way to add the parameter.
No change still falls over at the same point.

I have never entered a kernel parameter that manner. I always highlight the Boot: Manjaro option and press “e” on my keyboard. This brings you to the grub config that the Live ISO is using. I will then add the kernel parameter at the end of the line that has “quiet” in it. Then F10 to boot the system.

Another option is to use Manjaro Architect to do your install. There is a nice tutorial on it here: Install with Manjaro Architect I have had much better luck installing a system that way.

If this does not help, the problem is beyond my knowledge to fix.

1 Like

Only very specific drives are affected, mostly OEM it seems.
Kernel source code already has quirks for certain drive IDs.
See this thread for an example - there the boot parameter does not help.

1 Like

@torvic Nice patch in the linked thread. I personally have added it to my “bookmark arsenal of knowledge”. I know that my Samsung 970 EVO NVMEe needed the kernel parameter I suggested in order to work properly.

Well the thing is that I have no idea whether that patch actually works :wink:

Just the fact that it is there is good. Gives one something to work from if needed.

1 Like

when editing grub at boot, i dont think it has a GRUB_CMDLINE_LINUX_DEFAULT line, instead its a line beginning with “linux”, i usually just tell people to find the word “quiet” and replace it with the needed parameter. the line you mentioned is how its formatted in /etc/default/grub

1 Like

@dglt Thanks for catching that! I have edited my post accordingly.

Hi I’m interested, I have a 970 EVO too, with no problem however

ok I rebooted to grub menu, highlighted Boot: Manjaro and pressed e
at the end of the line I typed “nvme_core.default_ps_max_latency_us=5500” then pressed F10 and no change.
I checked out your link for architect and tbh I feel that is a bit over my experience level.

If you give me the exact details of your hardware and especially the SSD, I can add it to the patch referenced in the thread above.
Please give output of
lspci -nnn | grep -i nvme ; cat /sys/devices/virtual/dmi/id/board_{vendor,name}

If it works, we could ask philm to integrate it into Manjaro kernel.

1 Like

Made a little progress by the following action
highlighted Boot: Manjaro
Press e
replaced the word “quiet” with nomodeset
will see if I can pull info
Actually how do I go about getting the output requested?

Hmm well that’s a good question I must say.

Can you try again, removing “quiet”, and appending a “1” (one) at the end of the line?

Maybe I don’t need the output though.
Can you say whether your NVMe is a Samsung SM961?

This is the nvme drive

And this is what I get so far

will remove quiet and place a 1 at the end and report back

tried removing quiet and there was already a 1 at the end and its falling down at the same way as initial post.

Here is the updated patch, absolutely no idea if it will work.
I don’t know what the DMI name of your motherboard is, but I assumed “PRIME Z370-PRO” (capital letters). I also assumed that the SSD is a SM961.

--- a/drivers/nvme/host/pci.c	2019-02-28 20:15:24.606176186 +0100
+++ b/drivers/nvme/host/pci.c	2019-02-28 20:27:46.369325239 +0100
@@ -2441,11 +2441,20 @@
 		 * within few minutes after bootup on a Coffee Lake board -
 		 * ASUS PRIME Z370-A
 		 */
 		if (dmi_match(DMI_BOARD_VENDOR, "ASUSTeK COMPUTER INC.") &&
-		    (dmi_match(DMI_BOARD_NAME, "PRIME B350M-A") ||
+		    (dmi_match(DMI_BOARD_NAME, "PRIME B350M-A") || 
+		     dmi_match(DMI_BOARD_NAME, "PRIME Z370-PRO") ||
 		     dmi_match(DMI_BOARD_NAME, "PRIME Z370-A")))
 			return NVME_QUIRK_NO_APST;
+    } else if (pdev->vendor == 0x144d && pdev->device == 0xa804) {
+		/*
+		 * Samsung SM961 NVMe probably has a APST related problem
+		 * on Dell Precision 7510, so let's disable deepest ps.
+		 */
+		if (dmi_match(DMI_BOARD_VENDOR, "Dell Inc.") &&
+		     (dmi_match(DMI_BOARD_NAME, "Precision 7510")))
+			return NVME_QUIRK_NO_APST;
 	}
 
 	return 0;
 }

I have no idea where to even start with that sorry but I am a newbie.
My board is PRIME X370-Pro
My drive is the 960 Evo

I am currently compiling a kernel with the above patch included and I can upload it later.
However before you even think about installing that kernel, make sure you have backups of your data.

EDIT: Stupid boy, me. I forgot that you cannot install anything…

I’d like to know what @philm thinks of this. Am I wasting my time or could the quirk actually help?

EDIT 2:
Is it possible for you to unplug the NVMe drive?

Forum kindly sponsored by Bytemark