Unable to boot into manjaro

finally figured out how to post links
reddit post for more context and info ^https://www.reddit.com/r/linuxquestions/comments/pguz97/unable_to_access_bios_after_installing_manjaro/
when trying to boot into manjaro, i get thrown into grub rescue. Is there a way to get into manjaro and recover? if no, then how can i get rid of manjaro + GRUB w/o using a win10 USB to nuke the drive and reinstall win10?
Here are my current partitions. ^https://cdn.discordapp.com/attachments/693925504725549120/883367190009610260/unknown.png
partition 6 is the ESP i made during manjaro install. Partition 5 is root partition and partition 7 is home partition. Can i just format partitions 5, 6, and 7 to remove grub from my laptop?

What should i do now? Should I recover manjaro or nuke manjaro and GRUB?

What happened before you got into grub rescue? I’m no expert but you can use a live usb and then use chroot to access your system and hopefully repair it. If not you can use chroot to restore a backup or backup any files before you nuke it

sadly i was going to link a reddit post that i made explaining my situation but sadly the forum just doesnt let me make posts w/ links or images.

tried posting on manjaro subreddit but post attempts keep getting deleted

r/linuxquestions/comments/pguz97/unable_to_access_bios_after_installing_manjaro/ put this at the end of reddit . com/

Looks like you’re using EFI boot. You should have just attached the ESP for Manjaro the same as the Windows one, which is the 100MB Partition 1. No need to make a new one. Just don’t accidentally wipe the EFI partition or you won’t be able to boot into Windows anymore, and mount it to /boot/efi during installation.

That being said, you are using an Acer Nitro 5… from my personal experience, and seeing a lot of forum issues… Acer laptops do not play nice with Linux a lot of the time…

I mean, you can just boot into a Manjaro LiveISO/USB to remove the Manjaro stuff with GParted or the Calamares installer; delete the partitions and remake them. Or make a GParted LiveUSB and use that.

i have tried to set the bootloader onto the win10 bootloader by giving the 100mb partition the /boot/efi mount point and the boot flag but i would get given the “no EFI system partition detected” warning (seen here


Did you set the filesystem as fat32? If not, that might cause the issue.

Unable to boot into manjaro read this post for more context and important information about my situation

here is what my boot order looks like https://cdn.discordapp.com/attachments/693925504725549120/883534921208066118/20210903_221125.jpg

I plan on removing manjaro and grub from my system. Can i just boot into a live usb and run gparted to get rid of the 3 partitions? If yes, does it have a risk of bricking my laptop or losing data?

Is it with Manjaro installed? [Since Manjaro cannot boot with secure boot enabled]

If you erase those three partitions, the data on those will be deleted, others will be fine.
Do not delete the EFI Partition of Windows.

yes manjaro is installed i disabled secure boot when i installed manjaro initially. i deleted the boot entry for manjaro when i booted into manjaro. I had to enable secure boot in order to choose a file for a trusted boot entry.
and for the partitions i can just get rid of the partitions to get rid of manjaro and grub

It seems that the last ISOs gives that error with EFI partitions below 500MiB. If your partition is FAT32 and it’s mounted in /boot/efi, you are good to go.