Unable to Boot into Manjaro without using usb livecd

As a guy form this topic I have also installed Manjaro XFCE Edition (17.1.7) alongside windows 10. I am using UEFI to boot, but I don’t have an option to boot directly into Manjaro from harddrive(only from livecd grub, as said in the name of the topic). I have tried following this guide, but it haven’t helped me…
Using efibootmgr at booted Manjaro brings me that I don’t even have it as an option to boot with(only 2 other options: win10 and usb livecd).

Also I am totally new to Linux and might misunderstand a lot of things, I am sorry if my questions may sound frustrating to someone.

When booted to Manjaro, provide the output from terminal …
(please include your input command as well)

LANG=C
sudo parted -l
sudo blkid
findmnt -s
efibootmgr -v

note: ‘sudo parted -l’ ==> small ‘L’
What’s computer make and model?

[dorohedoro-lap@dorohedoro-lappc ~]$ sudo parted -l
[sudo] password for dorohedoro-lap: 
Model: ATA SanDisk SD6SF1M1 (scsi)
Disk /dev/sda: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  316MB   315MB   ntfs         Basic data partition          hidden, diag
 2      316MB   420MB   105MB   fat32        EFI system partition          boot, esp
 3      420MB   555MB   134MB                Microsoft reserved partition  msftres
 4      555MB   65,3GB  64,8GB  ntfs         Basic data partition          msftdata
 5      65,3GB  128GB   62,7GB  ext4


Model: ATA WDC WD10JPVX-22J (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  1000GB  1000GB  ntfs         Basic data partition  msftdata


Model: JetFlash Transcend 16GB (scsi)
Disk /dev/sdc: 15,8GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32,8kB  1742MB  1742MB  primary               boot
 2      1742MB  1746MB  4194kB  primary               esp

[dorohedoro-lap@dorohedoro-lappc ~]$ sudo blkid
/dev/sda1: LABEL="M-PM-^RM-PM->M-QM-^AM-QM-^AM-QM-^BM-PM-0M-PM-=M-PM->M-PM-2M-PM-8M-QM-^BM-QM-^L" UUID="48AE4A66AE4A4D1E" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="41fc8acc-6149-42bc-b4f1-e6924e8fa853"
/dev/sda2: UUID="924A-BAB4" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="574fa6b6-15bc-47b4-9654-875e6669581e"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="47004f06-4b62-4998-b97f-278aee98b720"
/dev/sda4: LABEL="Windows 10" UUID="3C784BBE784B7624" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="804b1d1e-624e-4741-993a-e24fac20d5bb"
/dev/sda5: UUID="88e9289f-2940-416c-b445-8638bafd36b1" TYPE="ext4" PARTUUID="37cb8486-d2aa-44e6-b366-3d56a7014de5"
/dev/sdb1: LABEL="Storage" UUID="3EFE2F64FE2F13A5" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="4bf9b9b4-8d48-4601-85c9-ab617c9f4359"
/dev/sdc1: UUID="2018-03-27-18-01-09-00" LABEL="MJRO1717" TYPE="iso9660"
/dev/sdc2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="586E-0BFD" TYPE="vfat"

[dorohedoro-lap@dorohedoro-lappc ~]$ findmnt -s
TARGET    SOURCE                               FSTYPE OPTIONS
/         UUID=88e9289f-2940-416c-b445-8638bafd36b1
                                               ext4   defaults,noatime,discard
/tmp      tmpfs                                tmpfs  defaults,noatime,mode=1777
/boot/efi UUID=924A-BAB4                       vfat   defaults

[dorohedoro-lap@dorohedoro-lappc ~]$ efibootmgr -v
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0000
Boot0000* Windows Boot Manager	HD(2,GPT,574fa6b6-15bc-47b4-9654-875e6669581e,0x96800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0001* UEFI: JetFlashTranscend 16GB 1.00	PciRoot(0x0)/Pci(0x14,0x0)/USB(17,0)/HD(2,MBR,0x0,0x33e7d4,0x2000)..BO

Right.

  1. What’s computer make and model?
  2. At terminal, do
    sudo grub-install
    sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
  3. then again
    efibootmgr
    Is there any ‘manjaro’ listed ? Print this out.
  4. Reboot ?
    Not successful again?
    Then when booted again to Manjaro
    at terminal, again. Print this out.
    efibootmgr -v
    ‘manjaro’ missing again?
  5. What’s computer make and model?
  1. The laptop is MSI GS70 2OD

  2. [dorohedoro-lap@dorohedoro-lappc ~]$ sudo grub-install
    [sudo] password for dorohedoro-lap:
    Installing for x86_64-efi platform.
    Installation finished. No error reported.
    [dorohedoro-lap@dorohedoro-lappc ~]$ sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

  3. [dorohedoro-lap@dorohedoro-lappc ~]$ efibootmgr
    BootCurrent: 0001
    Timeout: 1 seconds
    BootOrder: 0001,0000
    Boot0000* Windows Boot Manager
    Boot0001* UEFI: JetFlashTranscend 16GB 1.00

  4. Reboot did not help. Booting again through livecd’s grub into installed Manjaro.
    [dorohedoro-lap@dorohedoro-lappc ~]$ efibootmgr -v
    BootCurrent: 0001
    Timeout: 1 seconds
    BootOrder: 0001,0000
    Boot0000* Windows Boot Manager HD(2,GPT,574fa6b6-15bc-47b4-9654-875e6669581e,0x96800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}…a…
    Boot0001* UEFI: JetFlashTranscend 16GB 1.00 PciRoot(0x0)/Pci(0x14,0x0)/USB(17,0)/HD(2,MBR,0x0,0x33e7d4,0x2000)…BO

    Missing again…

  5. I might not know exact information you require, so I made this screenshot in windows system info.

Right. Yes. There was a very old post on MSI (gaming laptop?) with UEFI and it took a very difficult and long route in its bios setup to set any bootentry into its firmware. I’ll try to look for it somewhere and see if I can find it.

Meantime, poke (poke? :slightly_smiling_face:) around the bios-setup if you can find some where to get it into the firmware. Let us know if you can find it. look into ‘boot’, ‘security’, ‘default’ ‘enable bootloader’ , anything to see if there anything we can do about setting a ‘default’ bootloader.

BTW, you did disable ‘secure-boot’, right (when installing Manjaro)?

Yep, it’s a few years old(and so a bit outdated in that part) gaming laptop.

I have checked everything, but sadly nothing new :frowning: Here is a link to some photos of my bios.

When I was installing Manjaro, I set a boot option to ‘UEFI with CSM’, because with regular UEFI I couldn’t have disabled Secure Boot(it was grey and unselectable), and with ‘UEFI with CSM’ there just wasn’t such a paragraph in Security tab(and so I assumed Secure Boot was off in that mode).

And I missed ‘Advanced’ tab at first, so I added 1 more photo.

I have been searching and very sorry I just cannot find it.
Then I remembered it was an outside (long) website that shows in length the various ways to set up uefi in difficult computer setups. I think (not sure) when it comes to msi, there was a part where we need to reboot into bios again after adding a bootloader new path, (ie… \EFI\manjaro\grub64.efi) to select that new path as ‘default’. And (I think) there is a ‘security’ tab to allow this to happen.

I’m reluctant to say all these as I’m unsure if that is for msi. but I know for msi (some msi), it seems (to me) so difficult to just get this done. I was thinking that even if we poke around it without the guide, it would be difficult to even get it right.

Again, sorry i could help.
But a reminder about secure-boot (not sure after you mentioned it, if that is done right, again I don’t know) and this command will help in any uefi situations anywhere (which you have done)

So replying to you so that you do not wait for me.
Hope to hear from you with good news.

1 Like

Okay, I will dig up deeper with Google’s help and hope I’ll find something :slight_smile:
If I eventually find something I will message you either here or in private.
Thank you so much for your help and time nevertheless!

1 Like

Now, there is a rather ‘drastic solution’ for a Lenovo which just cannot get anything into its bootorder (efibootmgr) . Please read it first before doing anything. I don’t like such a ‘solution’ because it is simply not the right thing to do. Perhaps there’s no choice.

But if you do it, be aware you will need to

  1. copy the windows efi file up a directory
  2. make a custom.cfg for that windows

And still whenever there’s windows update that makes a new efi file, redo the process again.
And if manjaro create a new efi file (new grub version or grub-install), redo the process again.
(except the custom.cfg - custom cfg is much better, safer and easier than 40_custom).

If you need clarification, let us know.

[EDIT]
But try first

sudo efibootmgr -c -d /dev/sda -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

as shown here

Hopefully, you also do not have to do this ‘drastic method’ as the link.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.