Unable to boot from hd or USB after crash


I installed Manjaro on a partition of an old MacBook pro (2010, I think). I’ve been using Manjaro for about a month with no issues other than occasional crashes.

After a crash this morning, I have been unable to reboot.

I can get to the initial boot screen. If I go into the ‘Advanced options for Manjaro Linux’ tab, I have four options–the two kernels listed below and their fallback initramfs:

Manjaro Linux (Kernel: 5.9.11-3-MANJARO x64)
Manjaro Linux (Kernel: 5.8.18-1 MANJARO x64)

I have tried booting from all four, but the screen just stays blank.

After that failed, I tried rebooting from the USB thumb drive that I did the initial install from. In grub, the USB drive comes up as (hd0,msdos2). I did the following:

set root=(hd0, msdos2)
chainloader /efi/boot/bootx64.efi

This brings me to the ‘Welcome to Manjaro’ boot screen on the USB. I then tried:

Boot: Manjaro.x86_64 xfce

I assumed this would boot me in, but I end up with the same blank screen.

I then went into the ‘Detect EFI bootloaders’, which gives me two options:


I tried both of those, each of which kicks me back to the initial boot screen–and after hitting return, the same blank screen.

Any thoughts on how I might get booted in? If I can’t get back in to Manjaro, is there some way for me to retrieve my data?


Hi please check:

1 Like