Unable to boot because of fstab

Hey all, apologies for formatting, I’m on mobile cause computer is unusable. I’ve been stuck on this thing for awhile where I can’t mount my samba shares automatically, I got it to kinda work where it’s in fstab, but every restart I’ll see

[FAILED] Failed to mount /home/james/mountpoints/highwind.
[DEPEND] Dependency failed for Remote File Systems.
[FAILED] Failed to mount /home/james/mountpoints/home.

This was fine, it just meant a longer restart time. When I’d get logged in I’d run sudo mount -a , and it would mount correctly until a restart. Well I tried to make a script where it would run mount -a and put it in a crontab where at reboot it does that. I restarted to test it, and I’m stuck at the above screen now. The other kernel options in grub put me in emergency mode, and don’t actually let me type my password or Ctrl d. What do I do

Okay, so now I thought I fixed it, there was just an update and that seemed to mess something up. I got in on some 4.x.x kernel. Removed the crontab and my issue was still there. So I went back to that kernel, went into fstab, and commented out my samba shares. Now I just boot up to a black screen

Try using systemd mount and automount units.

This will ensure your system boots despite a missing share.

What do I do to get past this black screen though
When I access the 4.14.206 kernel, I don’t have internet access