Unable to boot after nvidia-prime-select install

Hello, i’m new on Manjaro,

I installed it few week ago in dual boot with windows.
I had no problem until I tryed to switch from Intel drivers to Nvidia drivers (that where installed) with nvidia-prime-select. I just followed the guide here : https://github.com/wildtruc/nvidia-prime-select.

Unfortunatly, system doesn’t boot anymore, no error, just stuck on Asus Logo after choosing grub Manjaro boot.

Any ideas to solve the boot ?
Here is my configuration :

Asus x751LDV
RAM : 12GO
Processor : Intel i7 4510U CPU | 2GHz - 2.6GhZ (fast)
64b

Thanks.
Would be great if I could avoid reinstalling system.

You should be able to revert from TTY any modification made by installing the nvidia-prime-select, and chose one of the 4 available approaches recommended for Manjaro.

If you boot with the nomodeset kernel parameter, and also replace quiet with 3 it should start in TTY, and as your user proceed with one of the above.

2 Likes

that particular prime-select is for fedora. dont forget to disable/remove any/all related services, configs and bbswitch packages before trying the other options

Thanks a lot.

Solution :

  • boot on grub swap
  • in the screen of choices (windows/Manjaro) select manjaro and press E.
  • edit configuration line where “/linux … quiet”. Replace “quiet” with “nomodeset 3”
  • CTRL Q
  • enter in TTY mode
  • log in
  • sudo nvidia-prime-select intel
  • stop computer
  • reboot

Uninstall nvidia-prime-select with pacman.

Solved all. Thanks !

Hello, a new message to ask for help a second time.

I tried to switch to PRIME with this tutorial you gave me :

But i can't boot anymore, i cand enter in TTY mode but startx fail.
In Xorg log I got :

(EE) no screens found(EE)
(EE) No devices detected. 

I tryed many things, maybe my configuration in Xorg is broken, do you have any ideas ?
Thanks !

most likely a configuration conflict. check
ls -la /etc/X11/xorg.conf.d/

if there is more than 1 video configuration in there you will have problems. also make sure any of those prime switching utilities and any of the services running from them are disabled and uninstalled.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.