Unable how to fix my boot setup with previously installed Grub Legacy


I have searched the web now for two days, but I cannot figure out how to fix my boot setup.

I have had previously PuppyLinux installed and added the Grub Bootloader. Afterwards I removed the partition for PuppyLinux and created a new one for Manjaro Linux. For whatever reason it still boots the Grub Legacy and I cannot figure out how to fix it.

I tried to figure out how Grub Legacy is installed, by using fdisk -l. This did only reveal a boot flag for my Manjaro Partition (/dev/sdb3). I could not find any hints about that it is installed in the MBR. There is another partition /dev/sdb1 which is only 100 MB in size. And it has the menu.lst of the PuppyLinux. I assume this is how Grub Legacy is installed. I am unable to figure out how to use Grub2 from Manjaro and remove Grub Legacy.

My partitions are:

/dev/sdb1: 100 MB partition with legacy grub
/dev/sdb2: Windows 10 OS
/dev/sdb3: Manjaro Linux
/dev/sdb4: Linux Swap

Does anybody know how to fix that? Help would be really appreciated. Thank you!


In the meanwhile I have collected some more diagnostic data.

I did a chroot into the installed Manjaro on /dev/sdb3.

[manjaro /]# inxi -Fazy
  12Kernel 5.10.30-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 10.2.0 
  12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_XFCE_2102 quiet systemd.show_status=1 
  apparmor=1 security=apparmor driver=free nouveau.modeset=1 i915.modeset=1 
  12Desktop Xfce 4.16.0 12tk Gtk 3.24.24 12info xfce4-panel 12wm xfwm4 12vt 7 12dm N/A 
  12Distro Manjaro Linux 12base Arch Linux 
  12Type Desktop 12Mobo ASRock 12model Z77 Pro3 12serial <filter> 
  12BIOS American Megatrends 12v P1.60 12date 09/12/2012 

(upower:27): UPower-WARNING **: 02:06:59.750: Cannot connect to upowerd: Could not connect: No such file or directory
  12Device-1 hidpp_battery_0 
  12model Logitech G305 Lightspeed Wireless Gaming Mouse 12serial <filter> 
  12charge Low 12status Discharging 
  12Info Quad Core 12model Intel Core i5-2500K 12socket BGA1155 12bits 64 12type MCP 
  12arch Sandy Bridge 12family 6 12model-id 2A (42) 12stepping 7 12microcode 2F 12cache 
  12L1 256 KiB 12L2 6 MiB 12L3 6 MiB 
  12flags avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 12bogomips 26400 
  12Speed 1600 MHz 12min/max 1600/3700 MHz 12base/boost 3300/3800 12volts 3.3 V 
  12ext-clock 100 MHz 12Core speeds (MHz) 121 1600 122 1600 123 1600 124 1600 
  12Vulnerabilities 12Type itlb_multihit 12status KVM: VMX disabled 
  12Type l1tf 
  12mitigation PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  12Type mds 12mitigation Clear CPU buffers; SMT disabled 
  12Type meltdown 12mitigation PTI 
  12Type spec_store_bypass 
  12mitigation Speculative Store Bypass disabled via prctl and seccomp 
  12Type spectre_v1 
  12mitigation usercopy/swapgs barriers and __user pointer sanitization 
  12Type spectre_v2 12mitigation Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  12Type srbds 12status Not affected 
  12Type tsx_async_abort 12status Not affected 
  12Device-1 Intel 2nd Generation Core Processor Family Integrated Graphics 
  12vendor ASRock 12driver i915 12v kernel 12bus-ID 00:02.0 12chip-ID 8086:0112 
  12class-ID 0380 
  12Device-2 NVIDIA GP106 [GeForce GTX 1060 6GB] 12driver nouveau 12v kernel 
  12bus-ID 01:00.0 12chip-ID 10de:1c03 12class-ID 0300 
  12Device-3 Logitech Webcam C270 12type USB 12driver snd-usb-audio,uvcvideo 
  12bus-ID 1-1.5.1:5 12chip-ID 046d:0825 12class-ID 0102 12serial <filter> 
  12Display x11 12server X.Org 1.20.11 12driver 12loaded nouveau 
  12note n/a (using device driver) 12display-ID :0.0 12screens 1 
  12Screen-1 0 12s-res 6400x1440 12s-dpi 96 12s-size 1693x381mm (66.7x15.0") 
  12s-diag 1735mm (68.3") 
  12Monitor-1 DP-3 12res 2560x1440 12hz 60 12dpi 109 12size 597x336mm (23.5x13.2") 
  12diag 685mm (27") 
  12Monitor-2 DP-4 12res 1920x1080 12hz 60 12dpi 122 12size 400x270mm (15.7x10.6") 
  12diag 483mm (19") 
  12Monitor-3 HDMI-3 12res 1920x1080 12hz 60 12dpi 92 12size 531x298mm (20.9x11.7") 
  12diag 609mm (24") 
  12OpenGL 12renderer NV136 12v 4.3 Mesa 21.0.2 12direct render Yes 
  12Device-1 Intel 7 Series/C216 Family High Definition Audio 12vendor ASRock 
  12driver snd_hda_intel 12v kernel 12bus-ID 00:1b.0 12chip-ID 8086:1e20 12class-ID 0403 
  12Device-2 NVIDIA GP106 High Definition Audio 12driver snd_hda_intel 12v kernel 
  12bus-ID 01:00.1 12chip-ID 10de:10f1 12class-ID 0403 
  12Device-3 Logitech Webcam C270 12type USB 12driver snd-usb-audio,uvcvideo 
  12bus-ID 1-1.5.1:5 12chip-ID 046d:0825 12class-ID 0102 12serial <filter> 
  12Device-4 SteelSeries ApS SteelSeries Arctis 7 12type USB 
  12driver hid-generic,snd-usb-audio,usbhid 12bus-ID 1-1.5.4:9 12chip-ID 1038:12ad 
  12class-ID 0300 
  12Sound Server-1 ALSA 12v k5.10.30-1-MANJARO 12running yes 
  12Sound Server-2 JACK 12v 0.125.0 12running no 
  12Sound Server-3 PulseAudio 12v 14.2 12running yes 
  12Sound Server-4 PipeWire 12v 0.3.25 12running no 
  12Device-1 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  12vendor ASRock 12driver r8169 12v kernel 12port d000 12bus-ID 05:00.0 
  12chip-ID 10ec:8168 12class-ID 0200 
  12IF enp5s0 12state up 12speed 1000 Mbps 12duplex full 12mac <filter> 
  12Device-1 Cambridge Silicon Radio Bluetooth Dongle (HCI mode) 12type USB 
  12driver btusb 12v 0.8 12bus-ID 1-1.6:4 12chip-ID 0a12:0001 12class-ID e001 
  12Report rfkill 12ID hci0 12rfk-id 0 12state down 12bt-service N/A 12rfk-block 
  12hardware no 12software yes 12address see --recommends 
  12Local Storage 12total 2.3 TiB 12used 6.2 GiB (0.3%) 
  12SMART Message Required tool smartctl not installed. Check --recommends 
  12ID-1 /dev/sda 12maj-min 8:0 12vendor Seagate 12model ST31500341AS 12size 1.36 TiB 
  12block-size 12physical 512 B 12logical 512 B 12speed 3.0 Gb/s 12serial <filter> 
  12rev CC1H 
  12ID-2 /dev/sdb 12maj-min 8:16 12vendor Samsung 12model SSD 840 EVO 500GB 
  12size 465.76 GiB 12block-size 12physical 512 B 12logical 512 B 12speed 6.0 Gb/s 
  12rotation SSD 12serial <filter> 12rev BB6Q 
  12ID-3 /dev/sdc 12maj-min 8:32 12vendor Samsung 12model SSD 860 EVO 500GB 
  12size 465.76 GiB 12block-size 12physical 512 B 12logical 512 B 12speed 3.0 Gb/s 
  12rotation SSD 12serial <filter> 12rev 3B6Q 
  12ID-4 /dev/sdd 12maj-min 8:48 12type USB 12model Mass Storage Device 12size 29.72 GiB 
  12block-size 12physical 512 B 12logical 512 B 12serial <filter> 12rev 1.00 
  12ID-1 / 12raw-size 42 GiB 12size 41.04 GiB (97.72%) 12used 6.2 GiB (15.1%) 12fs ext4 
  12block-size 4096 B 12dev /dev/sdb3 12maj-min 8:19 
  12Alert No swap data was found. 
  12System Temperatures 12cpu 34.0 C 12mobo N/A 12gpu nouveau 12temp 42.0 C 
  12Fan Speeds (RPM) N/A 12gpu nouveau 12fan 775 
  12Processes 220 12Uptime 2m 12wakeups 3 12Memory 23.37 GiB 12used 1.24 GiB (5.3%) 
  12Init systemd 12v 247 12tool systemctl 12Compilers 12gcc N/A 12Packages 12pacman 1057 
  12lib 298 12flatpak 0 12Client Unknown Client: systemd 12inxi 3.3.04 
[manjaro /]# efibootmgr -v
EFI variables are not supported on this system.
[manjaro /]# parted -l
Model: ATA ST31500341AS (scsi)
Disk /dev/sda: 1500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type      File system     Flags
 1      106MB   524GB   524GB   primary   ntfs
 2      524GB   1061GB  537GB   primary   ntfs
 3      1061GB  1500GB  439GB   extended
 5      1061GB  1492GB  431GB   logical   ext4
 6      1492GB  1500GB  8588MB  logical   linux-swap(v1)

Model: ATA Samsung SSD 840 (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system     Flags
 1      1049kB  106MB  105MB   primary  ntfs
 2      106MB   446GB  446GB   primary  ntfs
 3      446GB   492GB  45.1GB  primary  ext4            boot
 4      492GB   500GB  8590MB  primary  linux-swap(v1)

Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sdc: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  500GB  500GB  primary  ntfs

Model: Mass Storage Device (scsi)
Disk /dev/sdd: 31.9GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2524MB  2528MB  4194kB  primary               esp

[manjaro /]# blkid
/dev/sda1: BLOCK_SIZE="512" UUID="6C8C23B18C2374AC" TYPE="ntfs" PARTUUID="fd1d5fe4-01"
/dev/sda2: LABEL="Volume" BLOCK_SIZE="512" UUID="F8E42929E428EB96" TYPE="ntfs" PARTUUID="fd1d5fe4-02"
/dev/sda5: UUID="b20735be-3f3f-46f9-8256-9312e165dca4" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="fd1d5fe4-05"
/dev/sda6: UUID="0b958e1a-3226-4387-844c-8e95346a2e06" TYPE="swap" PARTUUID="fd1d5fe4-06"
/dev/sdb1: LABEL="System-reserviert" BLOCK_SIZE="512" UUID="66E0E9AEE0E984A1" TYPE="ntfs" PARTUUID="14cfda4b-01"
/dev/sdb2: BLOCK_SIZE="512" UUID="1880FEA780FE8A90" TYPE="ntfs" PARTUUID="14cfda4b-02"
/dev/sdb3: UUID="cdaf5181-fd78-4aa0-89a7-a85fd3b6b100" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="14cfda4b-03"
/dev/sdb4: UUID="94e434ce-fca2-411e-88bd-9f00ad286107" TYPE="swap" PARTUUID="14cfda4b-04"
/dev/sdc1: LABEL="Volume" BLOCK_SIZE="512" UUID="F6903BF1903BB6C9" TYPE="ntfs" PARTUUID="5d1fded6-01"
/dev/sdd1: BLOCK_SIZE="2048" UUID="2021-04-19-08-46-30-00" LABEL="MANJARO_XFCE_2102" TYPE="iso9660"
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
[manjaro /]# cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=cdaf5181-fd78-4aa0-89a7-a85fd3b6b100 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
[manjaro /]# cat /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki: https://wiki.archlinux.org/index.php/Fsck#Boot_time_checking

And here is a directory listing of /dev/sdb1. Which is the GRUB Legacy that gets loaded.

[manjaro /]# ls /mnt
'$RECYCLE.BIN'   Boot                         grldr               sdb_mbr.bak
 BOOTNXT        'System Volume Information'   menu-advanced.lst
 BOOTSECT.BAK    bootmgr                      menu.lst

boot on USB iso manjaro
open a terminal

sudo manjaro-chroot -a
grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sdb
exit ( end-chroot)

return to bios and boot

1 Like

Worked like a charm. Thanks a lot.

Still don’t get what went wrong. I assume that the MBR is using the bootloader from /dev/sdb1 and that still was the legacy grub. Is your command of grub-install checking the MBR to point to /dev/sdb3 or did it just change /dev/sdb1 and added grub2 instead of legacy grub?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.