UEFI not detecting Boot Partition on Razer Blade 15

Hello! I’m trying to install Manjaro on my Razer Blade 15 (2020) and it seems that the firmware can’t detect my /boot/efi partition. First I tried installing it using the graphical interface, then I used fdisk and efibootmgr to manually set things up but nothing changed.

parted -l

Model: SAMSUNG MZVLB256HBHQ-00A00 (nvme)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  538MB   537MB   fat32                 boot, esp
 2      538MB   38.3GB  37.7GB  ext4
 3      38.3GB  55.5GB  17.2GB  linux-swap(v1)        swap
 4      55.5GB  256GB   201GB   ext4

lsblk -fs

nvme0n1p1 vfat     FAT32                                 80E4-0A93                                           
nvme0n1p2 ext4     1.0                                   3d33d1cc-b715-4da7-a670-66618b38e483                
nvme0n1p3 swap     1                                     30f2e0aa-7ccb-4cdb-ade6-fceb2f09255f                
nvme0n1p4 ext4     1.0                                   147c69b8-4cdf-49d4-adfa-ea6db7a3c5b0                

efibootmgr -v

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000
Boot0000* manjaro	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0001* UEFI: DaneElecMicroUSB 1100	PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/CDROM(1,0x3fe36c,0x8000)..BO

This is my fstab:

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=80E4-0A93                            /boot/efi      vfat    umask=0077 0 2
UUID=3d33d1cc-b715-4da7-a670-66618b38e483 /              ext4    defaults,noatime 0 1
UUID=147c69b8-4cdf-49d4-adfa-ea6db7a3c5b0 /home          ext4    defaults,noatime 0 2

I tried manually installing grub by doing grub-install --recheck --no-rs-codes --modules="part_gpt part_msdos zstd" --efi-directory="/boot/efi" --target="x86_64-efi" but that didn’t work. It changes the efibootmgr -v output to HD(1,GPT,58f200b9-7c3d-1f45-92e2-4e50a50b4cc6,0x800,0x100000)/File(\EFI\manjaro\grubx64.efi) instead of the VenHw thing. But it still does not detect it and when I boot back into the live-usb it resets back to it’s original entry.

  • test -d /sys/firmware/efi && echo efi || echo bios checks out ok.
  • Secure boot is disabled
  • Fast boot is disabled
  • CSM is disabled

I’m not a noob at this. I no problem installing Manjaro on my desktop like 6 months ago. That being said I’m not the biggest expert either, so I’d love to get some help. Thanks.

If you can’t see the manjaro boot option in the uefi, i’d say it’s a firmware thing. All the info you posted corresponds to mine, besides the “efi” name for the boot, which should be completely irrelevant.

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  538MB   537MB   fat32           efi   boot, esp

I suspected the same thing myself. Other people online have gotten Arch working on the older models, so I hoped things would be different. Oh well… It wouldn’t hurt to try Ubuntu.

I just finished installing ubuntu without a hitch. I love Manjaro, but stability and having things work is more important to me than anything. Thank you for your help regardless.

I was going to tell you to:

  • Update your UEFI firmware
  • Try and install rEFInd, which is a Boot Manager, not a Boot Loader like grub as that got me out of multiple EFI boot issues.

So when you get sick and tired of Ubuntu (like me) and you come back here, you have 2 additional tools in your arsenal…


1 Like