Uefi and legacy boot the same computer

I bought a new/used Dell Latitude E7440. Nothing fancy, 8gb ram and 128Gb ssd (seller said 256), but flawless condition and dirt cheap, easy to upgrade later. Screen is excellent and touchpad passable.

Getting to know Dells firmware menu, I was happy to notice that it had excellent control over many issues. To my dismay I also discovered that the the preinstalled windows was installed in legacy mode, which explained the longer than expected boot time. I plugged in my USB installation (one of these https://www.sandisk.com/home/usb-flash/ultra-fit-usb). Dell happily created an uefi boot option for it, even helpfully tab completing into it. It felt like it wanted to boot linux. To my surprise I found that USB installation ran extremely smoothly, comparable to the ssd of my old system.

I had been planning to do installation on metal with manjaro-architect, but it automatically uses the boot method of running system, so it can only install uefi from this USB, and burning a live iso feels cumbersome, especially since I can’t use any pacman cache then. So currently I use manjaro from the USB in uefi mode, and Windows from ssd in legacy mode. I have to run through bios to change which one gets booted,which is kind of annoying.

Does anyone (@gohlip) know if grub can somehow chainload legacy boot bootloaders when installed in uefi mode? If not, I’ll probably need to convert windows to uefi somehow… Or dual boot in legacy mode, but I would prefer not to use that option. I’m in no hurry though, because the current temporary solution is actually fairly comfortable.

1 Like

If it is Windos 10, just download the Windows 10 iso and re-install. In mose cases you dont even need a product key. thats what we did :wink:

2 Likes

To be on the safe side:
https://www.microsoft.com/fr-fr/download/windows-usb-dvd-download-tool

http://www.nirsoft.net/utils/product_cd_key_viewer.html

And just reinstall, works like a charm even after upgrades from win7-8 to 10.

1 Like

Thanks. Maybe a clean reinstall is good in any case.

o bios-legacy grub cannot boot UEFI windows
o UEFI grub cannot boot bios-legacy windows.

But legacy-bios grub can boot uefi linux OS.
And uefi grub can boot bios-legacy linux OS.
Though I won’t recommend it if it can be avoided.

ps: enjoy your new system, have fun.
how are you settling in your new place?

oops: replied to Onf by mistake. sorry.

It’s not perfect, but has many things I’m happy about. Keyboard is good, although has no backlight. Feels very solid and seems easy to fix and upgrade. Never owned a business laptop before. Battery life is very solid. I was planning on getting this: https://www.power.fi/tietotekniikka/kannettavat-tietokoneet/asus-zenbook-ux430ua-pure2-14/p-504586/ but the Dell was 450€, practically unused. Less powerful, but much cheaper and has better connectivity. And I don’t need a super light laptop anymore after changing career (moving between continents on an aeroplane with small kids sucks big time).

I think I’m going to keep using this for quite some time. Upgrade ram and ssd when opportunity arises.

Any particular reason? I’ve found that using BIOS legacy with Windows 10 has been nice because when it upgrades (including the latest Creators Update) my dual boot MBR is left alone. It seems like with UEFI special precautions have to be taken to keep Windows from overwriting the bootloader.

Just a general point, if you bought a second-hand machine it’s worth wiping it down to bare metal in case the seller decided to be “cute” (and even then for new machines you avoid a lot of potential cruft and even things like SuperFish).

1 Like

Upgrade ram is best ROI (return on investment) as they are cheap nowadays.Though 8 GB is good enough for most purposes. SSD? meh… :slight_smile:, but if you one, try f2fs format.

ps: at least your kids are with you when you travel. I seldom see mine when they were toddlers when I travelled. I now seldom see them as now they are travelling.

A few.

  1. I have always used uefi and have had close to zero problems with it. I don’t like change.
  2. access to nice boot menu with refind.
  3. faster boot up. I like speed
  4. this uefi implementation seems to have nice controls for secure boot, so I might some day decide to play around with it.

It came with Windows just reinstalled

Yeah, that is why I was considering it anyway. I originally planned to do it, but then felt lazy because there was so little bloat.

Sounds sad.

Thing is, it was not just travel, but actually moving from one home to another. Can’t send cargo, does not arrive in Siberia. So it’s omnia mea mecum porto type of difficulty… But yeah, I would not want to be away from the little ones for long,especially since we are talking about span of years…

I have a dell laptop for a long time i couldn’t use UEFI boot because it couldn’t detect .efi file in my flash drive. The problem finally got solved from the March BIOS update, so you should apply the recent BIOS firmware update.
Then, reformat the whole drive in GPT while installing windows(if you are one of the rarely windows user like me) then install manjaro or mayle multi-linux boot!!!
Grub can handle that.

This maybe the official driver link for your laptop. As i can see there is a BIOS update issued in January 2017.
:beers:

Thanks for the tip! Uefi works fine already though, but a little bios upgrade never hurt anybody… :slight_smile:[quote=“Alpha, post:11, topic:22870”]
mayle multi-linux boot
[/quote]

I used to multiboot extensively, bur 128Gb is quite small for multiboot when one of them is windows… Maybe after I upgrade the ssd. Though I wonder what I would put there beside manjaro? Maybe calculate linux or void.

True but if you want some swift and fast KDE action, try KDE neon, like me you can be surprised how fast it updates and how smooth it runs.

Thank you for the tip

1 Like

regarding UEFI:

I find absolutely no “noticeable” difference in boot up speed between Legacy and uefi.
I use uefi for every other reason, but speed really isn’t one of them.

@Chrysostomus

yes, and also,
even if it’s still running win7, or 8, you can still download/install a win10 iso, and install/upgrade.
As Tids said, it may not even ask for the product key, but if it does then just put in the prod key from your existing win7/8/10. -or just use the “Magical Jelly Bean” product key finder, or similar, on your existing Windows.
then just do a clean uefi install of windows.

I made a quick howto win10 uefi install, for a remote good friend of mine, who got a 2nd ssd for Linux, but he wanted help installing Win10 cleanly on his 1st-Drive. -and Cortana helped too.
the ending is a bit sarcastic, but anyway…, enjoy :wink:


-haha.
:smile:

Nice, windows did one its updates without asking, now the touchpad does not work. The nipple mouse moves the pointer, but buttons do not work. First time I get this level of breakage from windows 10. I don’t feel that is acceptable behevior from paid for software that also sells my data to third parties. I think one should be able to expect better functionality for that price.

Behold the power of virtual monoply, I still need to reinstall it because of my work! :sweat_smile:

Rebooting windows did not help. Booting into manjaro, doing nothing and then booting windows fixed the issue! :smile: It knows it has competition :wink:

Aah, this is windows 10 pro, I knew it felt somehow different…

I run windows 10 pro its very customisable compared to older versions but still dog slow compared to linux and a virtual desktop to boot.

So, I created install media for Windows, switched partition table to gpt and started to install Windows. Media boots, but but Windows complains about partitions it created itself and refuses to use them. Sweet. It also worked its Windows magic, and made my linux installation, which was in completely other drive, unbootable. I’m not sure I’m comfortable with professional grade malware like this…

Forum kindly sponsored by