Über Audio-Player (VLC) Dateien von NAS (Synology) über smb wiedergeben


#1

Hallo allerseits,

ich bin Linuxanfänger.
Ich habe mein Synology NAS über smb als Netzlaufwerk eingebunden.
Ich kann auch problemfrei über Dolphin darauf zugreifen.

Jetzt möchte ich gerne meine Musikbibliothek anhören. Zum Beispiel über VLC.
Navigiere ich in VLC in das entsprechene Verzeichnis und starte ein flac file passiert nur leider nichts.

Weiß jemand wie man dieses Problem beheben kann?
Ich vermute es liegt irgendwie an der smb Einbindung.

Besten Dank schon mal für die Hilfe :slight_smile:


#2

Hallo Der_Isch,
bei solchen Problemen ist es ganz nützlich, wenn man Fehlermeldungen hat.
Also rufe mal vlc von Hand auf und poste, was angemeckert wird
vlc /pfad/zu/deiner/musikdatei
Pfad natürlich anpassen.
Ansonsten, als erste Vermutung: ist der Ordner freigegeben und stimmen die Zugriffsrechte?

viele Grüße gosia


#3

Hallo gosia,

danke für Deine Antwort.

Wenn ich im VLC Player über Medien -> Datei öffnen … gehe,
kann ich im aufploppenden Fenster unter Fremdgeräte mein Netzlaufwerk (auf einem NAS) auswählen und dann zu meiner flac Datei navigieren.
Die Datei wird dann im VLC aufgeführt, kann aber nicht abgespielt werden. Informationen über die Datei werden auch nicht angezeigt, ausschließlich der Dateiname.

Wenn ich in der VLC Oberfläche über Rechtsklick -> Datei hinzufügen … anwähle kommt anschließend folgende Fehlermeldung:
Die Datei oder der Ordner smb://User0_MB@192.168.178.11/Volume_MB/Eigene Dateien/Musik/EAC/Soundtracks/The Witcher 3 - Wild Hunt OST/01 The Trail.flac existiert nicht.

Nun existiert die Datei aber.
Ich habe auch bemerkt, dass in anderen Programmen das NAS bzw. der Ordner Volume_MB nicht zur Auswahl stehen. Das finde ich komisch.
Eine Vermutung ins blaue wäre, dass das NAS nicht korrekt in Manjaro eingebunden worden ist. Bzw. noch nicht komplett.

In Dolphin erscheint mein NAS Ordner Volume_MB ebenfalls unter Fremdgeräte. Vielleicht muss/kann man den irgendwie dauerhaft als Laufwerk einbinden? Da bin ich dann aber überfragt.


#4

Hmm, ich habe mal etwas recherchiert.
Im Prinzip sollte der Ordner auf dem NAS ordnungsgemäß hinzugefügt werden können mit folgendem Befehl:

mount -t cifs //192.168.178.XXX/drive_name/ /local_directory -o username=username,password=pwd,workgroup=xyz,iocharset=utf8,uid=1000,gid=1000

Dann bekomme ich aber folgenden Fehler:
mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Damit kann ich dann leider nichts anfangen. Gibt es dazu eine Idee. Es gibt zwar andere Foreneinträge zum Thema, aber bei denen steige ich nicht wirklich durch … Hilfe?!


#5

Hallo Der_Isch,

Es könnte sein, daß dein NAS nur die alte Version 1.0 beherrscht. da musst Du explizit angeben, daß Version 1.0 verwendet werden soll. Probiere mal:
sudo mount -t cifs -o vers=1.0,username=USER,password=PASSWORD //192.168.178.XXX/DIR MOUNTPOINT
entsprechend angepasst und ergänzt.
Nur um sicherzugehen:
smb.service und nmb.service laufen ordnungsgemäß?

viele Grüße gosia


#6

Hallo gosia,

der Hinweis war schon mal gut. Mit Deiner angegebenen Syntax hat es funktioniert.
Ich habe das Laufwerk danach noch mal unmountet und, wie auch oben angegeben, über gemountet:

mount -t cifs //192.168.178.XXX/drive_name /local_directory -o username=username,password=pwd

Das funktioniert nun auch.
Es kann sein, dass ich nach dem letzten Manjaro Update, bei dem auch der Kernel upgedatet worden ist, einen Neustart brauchte.

Mit dem gemounteten Ordern im “/local_directory”, dass bei mir im “/home” Ordner liegt, kann ich nun aus allen Programmen über das lokale Verzeichnis auf das NAS zugreifen.
Das Problem ist nun also gelöst :slight_smile:

Kannst Du mir noch einen Tipp geben, wird das NAS Laufwerk nun bei jedem Systemstart gemountet? Wenn nicht, wie kann ich das am geschicktesten umsetzten?

Besten Dank schon mal und viele Grüße


#7

Hallo Der_Isch,

da sieh dir mal diese zwei Möglichkeiten an
SystemD automount
autofs

viele Grüße gosia


#8

Super danke!

Ich habe nun in “/etc/fstab” folgende Zeile eingefügt:

//192.168.XXX.XXX/NAS_volume/ /home/user/NAS_volume/ cifs noauto,nofail,x-systemd.automount,x-systemd.device-timeout=60,_netdev,uid=1000,workgroup=workgroup,user=user_name,password=password

Die Zeile habe ich aus diesem Forenbeitrag abgeleitet:
https://de.manjaro.org/index.php?topic=3406.0

Damit läuft alles wie ich es mir wünsche.
Besten Dank und viele Grüße
Der_Isch


#9

Hallo,

ich muss noch mal etwas zurück rudern. So ganz perfekt ist doch noch nicht alles.
Das Einbinden der NAS Ordner funktioniert nun wie gewollt, ebenso der Zugriff von Programmen unter Manjaro.

Fahre ich den PC nun herunter bekomme ich für jeden über "/etc/fstab” eingebundenen Ordner folgende Fehlermeldung:
“A stop job is running for /home/user/NAS_volume/ (Xs of 1min 30s)” Wobei X von 0 bis 1min 30s hoch zählt.

Gibt es dazu Ideen?
Kann ich die 1min 30s ggf. auf 10s reduzieren?


#10

Hi gosia,

ich habe mich gegen die Variante über fstab entschieden und stattdessen den Weg über autofs gewählt.

Der Anleitung folgend habe ich nun folgendes getan:

  1. In der Datei “/etc/autofs/auto.master” habe ich eine neue Zeile hinzugefügt:
    /media/ /etc/autofs/auto.NAS --timeout=60 --ghost
  2. Im Verzeichnis “/etc/autofs/” eine neue Datei mit dem Namen “auto.NAS” angelegt. Diese hat den Inhalt:
    NAS -fstype=cifs,noauto,nofail,x-systemd.automount,x-systemd.device-timeout=60,_netdev,uid=1000,workgroup=workgroup,user=user,password=password /volume_1 ://192.168.XXX.XX/volume_1/ /volume_2 ://192.168.XXX.XX/volume_2/

Das Resultat sind zwei neue Ordner
/media/NAS/volume_1
und
/media/NAS/volume_2
die jeweils den Inhalts des Ordners auf dem NAS beinhalten.

Dies ist folglich die akkurate Variante ein NAS Share über autofs in Arch einzubinden.
Danke für die Links :slight_smile:
Ich kann nun ebenfalls aus allen Programmen auf die über autofs eingebundenen Laufwerke zugreifen.

Viele Grüße
Der_Isch


#11

Hmm, ich bin etwas verwirrt. Ich scheine mit diesem Ansatz keine Schreibrechte auf dem NAS zu haben.

Weiß jemand an welcher Stelle man ein und welches Kommando setzten muss um das zu beheben?
Konkret kann ich eine .ods (mit LibreOffice) nicht bearbeiten und speichern …


#12

Hallo Der_Isch,

hilft das hier?
Falsche Rechte

viele Grüße gosia


#13

Leider nein, sowohl “dreambox.autofs” als auch “auto.dreambox” existieren bei mir nicht …


#14

Ich habe die Optionen die ich beim fstab Eintrag weiter oben genutzt habe nun beim autofs Eintrag von cifs hinzugefügt. Meinen Beitrag oben habe ich dementsprechend angepasst.
Damit habe ich nun Lese- und Schreibrechte.

Was nun noch offen ist ist die Fehlermeldung mit dem “A stop job is running …”.
Es scheint so als würden shares die über autofs eingebunden sind, nicht automatisch bei Neustart oder Herunterfahren des PCs unmounted.
Ich werde mal den Ansatz über systemd versuchen, das scheint hier etwas fortschrittlicher zu sein.


#15

Mit Empfehlung von @gosia, habe ich nun auch den Weg über systemd probiert.
Dafür habe ich mir die entsprechenden Tutorials samba und systemd angesehen.

Dann habe ich folgendes getan:

  1. In “/etc/systemd/system/” habe ich ein neues File “mnt-volume_1.mount” erstellt, dass folgenden Inhalt hat:
[Unit]
Description=Mount Volume_1 at boot
Requires=systemd-networkd.service
After=network-online.target
Wants=network-online.target

[Mount]
What=//192.168.XXX.XX/volume_1
Where=/mnt/volume_1
Options=noauto,nofail,x-systemd.automount,_netdev,uid=1000,credentials=/etc/samba/credentials/volume_1,workgroup=workgroup
Type=cifs
TimeoutSec=30

[Install]
WantedBy=multi-user.target
  1. Ich bin der Empfehlung im samba tutorial (Storing share passwords) gefolgt und habe ein entsprechendes credentials File in “/etc/samba/credentials/volume_1” erstellt, dass folgenden Inhalt besitzt:
username=myuser
password=mypass

Dieses File wird danach nur noch root zugänglich gemacht:

# chown root:root /etc/samba/credentials
# chmod 700 /etc/samba/credentials
# chmod 600 /etc/samba/credentials/volume_1
  1. Dann kann man testen ob der neu eingerichtete Service auch funktioniert. Dafür startet man ihn:
systemctl start mnt-volume_1.mount

überprüft seinen Status:

systemctl status mnt-volume_1.mount

und gibt ihn anschließend zum Starten beim Bootvorgang frei:

systemctl enabled mnt-volume_1.mount

Das sollte es sein.
Was ich soweit schon sagen kann ist, dass der Zugriff auf die Dateien auf meinem NAS deutlich schneller abläuft als mit der autofs Lösung. Warum weiß ich nicht.

Noch offen ist ob das Problem mit “a stop job is running …” damit auch behoben ist. Ich werde berichten.