Two drives, loads of partitions, two Manjaros and Wind10, won't boot automatically

ah.. you have 2 drives..
Try sda also.

sudo grub-install --target=i386-pc  --force  --recheck /dev/nvme0n1
sudo grub-install /dev/sda
sudo update-grub

Is your sda internal?
If external, just pull it off.

ps: I did not see your you-tube.

Second drive is just data, full of personal files, no OSes. I have to leave for a couple of hours right now, I'll try to do that when I get back and I'll update you.
Watch that video, it might give some more info than I can explain. Thank you all

. . . .

It's an old, internal, sata3 HDD that's been in my computer for more than 5 years now

Do the 2 grub-install commands.
It (your failed boot, and your you-tube boot) was trying to boot from sda.

@AgentS

I wonder why when I ask people to do grub-install on multiple disks (in bios-legacy grubs)
people are skeptical. On more than 4 occasions they walked away from my suggestion. But here's one (so as not to embarrass the others who don't do it) where the OP did it and was happy with the results.

sudo grub-install /dev/sda
sudo grub-install /dev/sdb
sudo grub-install /dev/sdc
sudo grub-install /dev/sdd

Can you please explain to me why they are skeptical?
Or a better way to persuade them?
Perhaps easier to persuade them to use a single disk? :laughing:

I am not sceptical and not scared to do so, as I mentioned above I had to leave my house and I'll be back on my Desktop in around 5-6 hours and then I will run these commands and update you on how everything went.
I could ssh into my Desktop and run these commands, but still I could test if that worked in couple of hours

Thank you again for this info <3

Explain what is the reason, together with your advice, might help.
I wouldn't like to do thinks I don't understand, but sometimes when tired or disappointed I may comply.. But that's just me :wink:

On Topic, I see this is a hardware/firmware issue IMHO. Booting the same drive like the one that is already set as 1st boot order in BIOS (it's showed in the video, Samsung is 1st boot), gives different results.

I believe the nvme drive is recognized late from BIOS or Grub.
Explanation (if assumed correctly):

  • Grub (auto-script) probes first before actually setting (root)=, so it maybe unable to find it by UUID and skips to an error.
  • After hot restart, the drive is awake and BIOS/Grub finds it (UUID) and boots normally.

I have three proposals for a solution.

  1. Workaround
    • Install grub to HDD (secondary) drive. It is internal, so it's not normally going anywhere, unless broken.
    • Set the HDD as 1st boot drive in BIOS
  2. Custom "fix" (not sure it will work as I imagine, needs testing)
    • Create a custom entry in Grub
    • One possible "fix" maybe to remove the probing at root selection part and assign root directly to UUID of Manjaro partition
    • Another possible "fix" might be to set a time delay (3-7 sec) right after the probe command and before the actual set root=, in hope that the drive will wake up and be caught.
    • Or try with a pure custom entry as usual, no probing.
  3. Proper official way
    • Check for an updated BIOS firmware, or request a BIOS fix from the vendor.

@Sidicer will decide anyway :wink:

4 Likes

@AgentS @gohlip
Installing grub in the secondary HDD did not fix the problem, but I did not try to set the HDD as a first boot priority (because when I try to boot the secondary HDD I get an error that linux kernel wasn't found).

Updating BIOS did not help either ..

Did you do these commands?

Yes I copied everything exactly as you posted. What bothers me is that every time I run sudo update-grub I get this error:

/usr/bin/grub-probe: warning: unknown device type nvme0n1.

Just ignore - I have the same message on my laptop - it has no bearing on how the grub is created

Okay. As petsam mentioned, you may need to get your bios firmware updated (to handle nvme with a hdd). Until that happen, can you try to remove the hdd (data only you said) and see if that resolves the issue? If it is resolved, a bios firmware update may help.

On

/usr/bin/grub-probe: warning: unknown device type nvme0n1.

Don't worry about it. it is a non-serious or fatal thing with memtest on nvme disk.
This link and post will clarify. Don't worry about it for now. We have bigger fish to fry (more important thinhgs to worry about).

Just remove the hdd and see if that resolves the issue.

@Sidicer

There's one thing that needs clarification.
You have nvme disk and yet you are on bios-legacy.
That is highly unusual and most nvme disk posts I've seen are on uefi. (I don't have nvme).
Can you boot to windows and check if indeed your windows is bios-legacy?
I know your partitions do not show any $esp (in fat32 format) except for your /dev/sdd DT microDuo which I take it as the install usb (if it is not the install media, please shout it out now). I've also read somewhere but I am not sure that nvme disk cannot booted in bios-legacy unless using some unusual bootloader like Clover.

Can you clarify this? Thanks.

ps: Here's one post where nvme is in bios-legacy and where using "--force" works.

1 Like

Yes I had left my install usb plugged in to try take screenshots from bios but didn't format it yet.

I might be on legacy boot because a year ago I changed a lot of settings in BIOS and I don't remember what I changed, all I know is that if I plug my Install USB I have two choices:
Boot USB
UEFI: Boot USB

Okay. Thanks for confirming sdd is install media.
If windows is indeed bios-legacy (which I think it is), using --force as per the the link should work, as it had in that 2 occasions.

grub-install --target=i386-pc --force --recheck --debug /dev/nvme0n1

If it doesn't work for you, I am at a loss why it didn't work for you other than a bios-firmware problem.

So I will have to take leave here but hope you fix it and let us know how you got it fixed.
Good luck, take care.

1 Like

Thank you for the info you've provided! I'll try everything and I'll update you! Peace

1 Like

BIOS/Motherboard only finds my NVME and HDD if I set to look for Legacy drives only. If I turn on UEFI - BIOS Shows that no drives are connected..

I will need to look into if you can change Win/Man already installed OSs to UEFI, Because for now I cannot reinstall Windows nor Manjaro

Yes their is a windows program to do just that never used it but it said to work.

Windows has MBR to GPT Converter built in into offline recovery tools. Sadly Manjaro doesn't. Only thing I can do is remove Manjaro partition, Convert windows partition from MBR to GPT and then split off a partition again and install a fresh copy of Manjaro

Forum kindly sponsored by Bytemark