Two different laptops with recent Manjaro installation won't boot and charge

Hey everyone,

After I made the switch to Manjaro a few months back, I also installed Manjaro on two of my older laptops, which I only incidentally use. This morning, upon working on a project for my Pi, I needed my old laptops because of the SD card slot. However, I quickly found out that they wouldn’t charge and also wouldn’t boot. One of those laptops, which is very old, used to run Windows 7 until I put Manjaro on there a few months back. It always booted up until today, even when there were years in between. After the initial Manjaro installation a few months back, I don’t think I’ve booted these laptops, since they’re not my daily drivers.

What might be going on here?

Welcome to the forum! :slight_smile:

On a laptop, the power from the mains usually goes into the battery, and from there to the motherboard. So if the battery’s completely out of juice, then you’ll need to have it charged for a while before you can turn on the laptop.

That said, there is a second battery ─ the size of a coin, connected to the motherboard directly, and usually of the CR 2032 type ─ for maintaining the CMOS NVRAM memory, which among other things contains the BIOS/UEFI settings and keeps the clock ticking. These batteries do also wear out over time, and especially so if the computer is not being used and is not connected to the mains.

CR 2032 batteries are easy to come by, and you’ll probably need to replace them in both of your laptops. However, if the main laptop batteries themselves won’t charge anymore ─ not even after leaving them plugged in for hours ─ then that’s going to be a bigger problem, especially if those laptops are old. Maybe you’ll still be able to find replacement batteries for them, but there’s no guarantee. :man_shrugging:

1 Like

If you cannot boot at all on battery – not even reaching BIOS – and keeping it plugged for a night between tries doesn’t change this, your battery is very likely dead.

2 Likes

Thanks you for the replies. I’ve in the meantime managed to boot the oldest laptop, a Packard Bell from around 2009, by removing the battery. It can boot while being plugged. However, charging the battery doesn’t seem to work. That does mean that I’ve managed to used the SD slot, so the reason I ran into this problem is fixed - this issue doesn’t have much urgency, but I would like to have it fixed if possible.

It could be that both batteries died in the last few months, but I find the coincidence rather odd. One laptop has been working since about 2009, the other since 2014, and both laptops still worked in May or June (one running Windows 7, the other running Fedora). Both have stopped working since installing Manjaro. Isn’t there a chance that somehow Manjaro has issues with recharging (a drained) battery?

In the meantime, I’ll leave them charging and see what happens.

AFAIK battery recharging is handled by the hardware, so the result would have been the same whatever systems you have installed.

1 Like

Ah okay. Well a little update. The oldest laptop with the removable battery now boots again with battery. I saw a video in which the advice was: remove charger, remove battery, hold power down for 30 seconds, put battery back in again and then charge. A red light started blinking straight away and after a few minutes I tried booting with the battery in and this worked. So now I’ve got this one turned off and I’ll just leave it charging.

The other laptop is being charged, but the charging light isn’t on or blinking or anything. However, it doesn’t have a removable battery like the other one. Does anyone know of a similar trick to maybe do the same as the above? Or would that mean opening it up?

I managed to charge both laptops in the end after trying a few different chargers and leaving them on for several hours.