Turning off bluetooth not staying put

Gnome → Settings → Bluetooth → Switch off the radio button. Bluetooth turn off but turns back ON on reboot. Is this a bug?

Hi @Kevin77,

Atter some searching, I came across this page, that states:

Actually changing /etc/bluetooth/main.conf was enough for me.

Search for the entry:


and change the value to:


Hope this helps!

Thanks @Midarthos but it did not help. AutoEnable is already set false (its the default) in the file.

Try to execute:

gsettings set org.blueman.plugins.powermanager auto-power-on false

And if necessary:
sudo rfkill block bluetooth

How does this (rfkill) make the radio button work?


$ gsettings get org.blueman.plugins.powermanager auto-power-on
No such schema “org.blueman.plugins.powermanager”

I have the same issue after stable update.
I tried to run sudo systemctl disable bluethooth then reboot. But “bluetooth Off” is shown in the Gnome status menu. Normally it should not be shown.

I got the log error journalctl -p 3 -b

kernel: Bluetooth: hci0: Reading supported features failed (-16)

It happens after the stable update. I am using Linux kernel 5.15, Linux 5.10 has the same issue.

1 Like

This should be treated as a bug and looked into I suppose


  1. sudo systemctl disable tlp
  2. pamac remove tlp
  3. sudo systemctl disable bluethooth
  4. reboot

The issue is gone.

This is akin to disabling a hardware if its driver doesn’t work properly :slight_smile: You’ve lost a bunch of critical functionality there.

Only disable bluetooth, nothing more.
But tlp has nothing to do with hardware drivers. This is laptop battery power.
You do not need tlp, because Gnome 41 has its own power manager that is called “power mode” in the Gnome status menu and Gnome setting.

“power mode” looks like:

If you enable TLP, then the feature “power mode” is gone and TLP forces Bluetooth to be displayed (you should config somewhere).

I know. That was an analogy I referred to.

You do not need to run systemctl. Just turn Bluetooth off or on in the Gnome setting. It does not change after reboot, when no tlp is used.
Just remove tlp, then the problem will be solved.

Guess I’ll live with this minor annoyance/bug. Without tlp the battery life is <3 hours. With tlp the battery power is >9.5 hrs almost on par with Windows.

There is Gnome Power Mode:

I am using the Gnome extension “CPU Power Manager” that is simple.

Yes, with this gnome’s power management my battery power is good for only <3 hrs

I recommend to use it if you use Intel. The extension can control CPU frequency and power.