Trying to update an "old" netbook


#1

good morning everybody :slight_smile:
Yesterday I took out a 32 bit Acer netbook with Manjaro OpenBox on it, not used (or updated for maybe 2 years) and tried to update it (I should hand this machine to a relative who’ll use it for web browsing and not much else) but with not much success… I first tried to update only Firefox and it did, but then Firefox doesn’t work anymore (error message: could’t load XPCOM) then guessing it’s something newer version of FF need and missing from this old os I tried to update everything with the “classic” pacman -Syy and pacman -Suu. It turned out a huge mess because I got a very long list of corrupted packages and no update.
I tried to fix it by refreshing the mirrors list, and I got asked a very long list of pgp keys attached to names that didn’t mean much to me. I then found this page of the wiki:
https://wiki.manjaro.org/index.php?title=Pacman_troubleshooting
and tried to follow it… the “One recipe for fixing this” doesn’t work as to the command:
sudo pacman -U http://repo.stdout.net/manjaro/pool/overlay/manjaro-keyring-yyyymmdd-x-any.pkg.tar.xz
I get the usual “invalid or corrupted package” message :frowning:
“Error about keys” section has been more useful, even if at point 2 I usually get an error message that more or less says “have you already done point 3’”. Howver after these commands I got a much shorter list of names whose pgp keys I’m asked to import (the only name I recognized was Philip Müller), I said yes and… nothing changed, it still doesn’t update the packages…
Any (quickish, I don’t want to loose too much time on this) way to fix this mess? (I’m wondering about a clean install).
Thanks :smiley:


#2

forgot to add: kernel on this machine is linux48, tried to update to 49 but I got the usual error about corrupted packages and it fails.


#3

Hi. Support for 32 bit architecture in Manjaro has ended, so maybe the best option is to install a distro that still has it.


#4

yes, I was aware of that… one of the reasons I was trying this last update is this… still I’d prefer to keep Manjaro but if there’s no easy & quick way I’ll just install something else, I could have a look at Haiku… thanks for the reply!


#5

All the best with finding the right 32-bit OS for your Netbook.

More power to you.

Ruziel :slight_smile:


#6

Take a look here List of distributions for 32bit x86 hardware [Wiki], you should find something nice :smiley:


#7

17.0.5 still provides 32-bit ISO’s, so those can be used. But they won’t get many updates from November and forward.

The quickest way to get around your problem is a re-install. If you don’t have any data on it you want to keep.
The OpenBox version of Manjaro is not a community edition anymore, but thankfully @napcok created Mabox Linux. It’s a 17.0.2 version, but it should update alright.

If not, you should be able to ask @napcok for help, since he’s the Maintainer of it.


#8

Yes, but he shouldn’t be getting errors on start or when updating. This still looks like an odd problem.

Said this, I wonder why people never ever specify their hardware specs in details in these threads…


#9

The reason you get those issues with updates is most probably because you haven’t updated it for 2 years and there have been many major changes in the core system during this time.

If you want to stay arch-based, there is archlinux32. From what I understand, you can even switch your 32-bit Manjaro installation to archlinux32.


#10

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.