Trying to modify /etc/fstab getting save error

I wonder if it has to do with the version of kde I am on:

Operating System: Manjaro Linux
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Kernel Version: 5.16.2-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-10510U CPU @ 1.80GHz
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics

How did you produce that data set in your post above?

I know that I’m on “stable”
and I know that that is not the version I’m running.
5.23.4-1 is what I have here …

In KDE System Settings there is a About screen and in that screen there is a copy to clipboard button.

yep - thanks

as I said:
I’m on Manjaro stable
and my KDE Plasma Version isn’t 5.24.80 - (but 5.23.4)
and my KDE Frameworks Version isn’t 5.91.0 - (but 5.89.0)

You are not running the stable version.

1 Like

Right I know that but where would I look to see if this problem has to do with that?

I found this in the Manjaro wiki:

Editing files requiring privilege escalation
WarningNever use sudo to run a graphical text editor. This can have unintended consequences or break the permission to configuration files that should not be owned by root.

Many of the graphical text editors will automatically ask for privilege escalation when they detect that you cannot write to a file.

If they don't, you can save a copy of the file to your home folder and move it into place using sudo. For example, if you edit your fstab and then saved a copy to your home folder, you could then move it to the proper location with sudo:
user $ sudo mv ~/fstab /etc/fstab 

But it doesn’t tell him what to look for if this doesn’t work as described.

As far as I know KDE is at 5.23.5 in Testing branch, and same in Unstable. Something is weird here.
Can you tell us what you hide from your system? What did you do that you’re not telling us?

We did try - until we finally found this.
I would not waste my time trying to find out

KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.91.0

This combination is something home made - it’s neither stable nor testing nor unstable.

Instead I’d restore to some supported branch
and then be asking questions if the problem remains.

It is not even the KDE Unstable repo/branch, it is literally the KDE BETA… so… obviously no support here.

Plasma 5.24 Beta is aimed at testers, developers, and bug-hunters.

The final version of Plasma 5.24 will become available for the general public on the 8th of February.

DISCLAIMER: This release contains untested and unstable software. Do not use in a production environment and do not use as your daily work environment. You risk crashes and loss of data.

1 Like

Be honest, you installed it from Chaotic AUR, right @MAYBL8 ?

What a waste of time of people trying to help…

Inxi was not provided. It would have shown what now was hidden

Wow , I didn’t expect that kind of reaction here. Debian yes but not here.
I didn’t know that this was something unsupported. I will go get what is supported if that will help.
Please forgive me .
I don’t remember how I got this version but it was offered somehow.
Can you help me get to unstable then or am I on my own?

I got it from adding this to pacman.conf

Include = /etc/pacman.d/mirrorlist

Should I get rid of this so I can get support?

1 Like

As far as I can see, KDE Unstable branch/repo is also on 5.23 so I think you’re still hiding something because I do not see any KDE package at 5.24 version in any Manjaro repo.

I am not hiding anything. Ignorance maybe but not hiding anything.

  Host: manjaro Kernel: 5.10.93-1-MANJARO x86_64 bits: 64 compiler: gcc
    v: 11.1.0 Desktop: KDE Plasma 5.24.80 tk: Qt 5.15.2 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: HP product: HP Spectre x360 Convertible 15-df1xxx
    v: N/A serial: <superuser required> Chassis: type: 31
    serial: <superuser required>
  Mobo: HP model: 863F v: 54.24 serial: <superuser required> UEFI: AMI
    v: F.26 date: 07/09/2021
  ID-1: BAT0 charge: 53.2 Wh (79.2%) condition: 67.2/67.2 Wh (100.0%)
    volts: 12.3 min: 11.6 model: HP Primary type: Li-ion serial: SerialNumber
    status: N/A cycles: 170
  Device-1: hid-0018:04F3:2992.0001-battery model: ELAN2514:00 04F3:2992
    serial: N/A charge: N/A status: N/A
  Info: quad core model: Intel Core i7-10510U bits: 64 type: MT MCP
    smt: enabled arch: Comet/Whiskey Lake note: check rev: C cache: L1: 256 KiB
    L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 700 min/max: 400/4900 cores: 1: 700 2: 700 3: 700
    4: 700 5: 700 6: 700 7: 700 8: 700 bogomips: 36812
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9b41 class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX250] vendor: Hewlett-Packard
    driver: nvidia v: 495.46 bus-ID: 3b:00.0 chip-ID: 10de:1d13 class-ID: 0302
  Device-3: Chicony HP Wide Vision FHD Camera type: USB driver: uvcvideo
    bus-ID: 1-5:2 chip-ID: 04f2:b67b class-ID: 0e02 serial: 200901010001
  Display: x11 server: compositor: kwin_x11 driver:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,nv,vesa
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Hewlett-Packard
    driver: sof-audio-pci bus-ID: 00:1f.3 chip-ID: 8086:02c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.10.93-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: 0c:dd:24:ab:82:13
  Local Storage: total: 931.51 GiB used: 106.4 GiB (11.4%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: S59ANS0N809758J rev: 2B2QEXM7 temp: 32.9 C scheme: GPT
  ID-1: / size: 235 GiB used: 59.96 GiB (25.5%) fs: ext4 dev: /dev/nvme0n1p11
  ID-2: /boot/efi size: 96 MiB used: 66.7 MiB (69.5%) fs: vfat
    dev: /dev/nvme0n1p2
  Alert: No swap data was found.
  System Temperatures: cpu: 40.0 C pch: 37.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Packages: pacman: 1342
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
  Processes: 260 Uptime: 11h 16m wakeups: 1855 Memory: 15.27 GiB
  used: 3.09 GiB (20.2%) Init: systemd v: 250 Compilers: gcc: 11.1.0
  clang: 13.0.0 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12

1 Like

Using your current mirror used, check by yourself here Index of /pub/manjaro/unstable/kde-unstable/x86_64 search for 5.23 (CTRL+F in any decent application) and all KDE packages will be found, search for 5.24, none, zero, nada. Your 5.24 KDE installation doesn’t come from here to me.

//EDIT: Now if you don’t know what you have done to your Manjaro installation, I think it is on you to remember what you have done and to find out. It takes some nerve to ask people to fix your :poop: after wasting their time for 40+ posts.

I’m trying to figure out how I got this. I’m not sure.
I guess I will reinstall and see what happens.

I think this is what I read and this is how I got to here.

OK I took the kde-unstable out or pacman.conf and downgraded.
This is what I have now:

Operating System: Manjaro Linux
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.2-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-10510U CPU @ 1.80GHz
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics

OK problem solved.
So that is what it was.
Let’s call it lesson learned.
I apologize for misleading anyone. Not my intention.
I am now going to see if I can get my /home moved as what started this post.
Thanks everyone for your help and I will be careful next time with what I am doing.
Please don’t forum shame me.


Don’t waste people’s time, and nobody will mention it.


As I said before and have apologized I didn’t mean to do that.
I will be better in the future. Sorry Sorry Sorry. What more can I do?

1 Like

Rethink twice next time before asking for help. What you did can’t happen without knowing it. :wink: