Trying to install LCD-show on Manjaro ARM (Raspberry Pi 3)

Hey Community,

I was trying to install
But unlucky it doesn’t work for some reasons.:

/etc/rc.local doesn’t exist (resolved by installing pcp)
/etc/modules doesn’t exist on Archlinux ARM (or based Systems)
the Script does not detect cmake when it was installed by or not the Script.

After reboot the System doesn’t come up again.
Tried on Arch Linux ARM as well no luck.

rc.local sounds like an OpenRC specific thing. We don’t have that, we use systemd. So if the software relies on that, you are out of luck.

/etc/modules is now /etc/modules.d/, again the reason is systemd.

The script looks like it’s just designed for Raspian/Raspberry Pi OS. It also looks to be running the build commands (make and cmake) with sudo, which you should never do.

You might be better off by creating yourself an Arch script loosely based on that script. It’s clear that the maintainer does not actually run Arch and have likely not tried the script on Arch.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.