Trying to install Gitkraken, no luck at all

newbie
aur

#1

Greetings fellow users, yesterday I was trying to setup Gitkraken from the AUR. But the program fails to launch and show me this:

/usr/bin/gitkraken: line 3: 1946 Segmentation fault (core dumped) LD_PRELOAD=/usr/lib/libcurl-openssl-1.0.so.4.4.0 /opt/gitkraken/gitkraken “$@”

What I’ve tried to do:

  1. Fallback Gitkraken to version 2.7, same error… Wich gives me the hint that the problem is not with Gitkraken itself, but with openssl.
  2. Resintall openssl + looking for something in that direction. No luck so far…
    ( yaourt -Sy libcurl-openssl-1.0 --noconfirm )
  3. Set up environmental variables (maybe something is missing?), but nothing changes…
    (env “LD_PRELOAD=/usr/lib/libcurl-openssl-1.0.so.4.4.0” /opt/gitkraken/gitkraken ) plus variations.
  4. Installing some libcurl stuff.

Any hints?

Ty, for your help!

PS: This is a fresh Manjaro install. I was using Manjaro + deepin before with no issues for over a year…
EDIT: Im using Manjaro Budgie atm.


#2
LD_PRELOAD=/usr/lib/libcurl.so.3 gitkraken

#3

File exists, but it gives me a warning: shell level too high…

Running

ls -l /usr/lib/libcurl-openssl-1.0*

Outputs:

lrwxrwxrwx 1 root root 28 set 17 20:33 /usr/lib/libcurl-openssl-1.0.so -> libcurl-openssl-1.0.so.4.4.0
-rwxr-xr-x 1 root root 489464 set 17 20:33 /usr/lib/libcurl-openssl-1.0.so.4.4.0

/usr/lib/libcurl-openssl-1.0:
total 0
lrwxrwxrwx 1 root root 31 set 17 20:33 libcurl.so -> …/libcurl-openssl-1.0.so.4.4.0
lrwxrwxrwx 1 root root 31 set 17 20:33 libcurl.so.4 -> …/libcurl-openssl-1.0.so.4.4.0
lrwxrwxrwx 1 root root 31 set 17 20:33 libcurl.so.4.4.0 -> …/libcurl-openssl-1.0.so.4.4.0


#4

More info:
Here is the lines that ive tried:

LD_PRELOAD=/usr/lib/libcurl-openssl-1.0.so.4.4.0 /opt/gitkraken/gitkraken "$@"
LD_PRELOAD=/usr/lib/libcurl-compat.so.4.4.0 /opt/gitkraken/gitkraken "$@"
LD_PRELOAD=/usr/lib/libcurl-openssl-1.0.so /opt/gitkraken/gitkraken “$@”

Output from ls

ls /usr/lib/libcurl*.*

/usr/lib/libcurl-compat.so.4.4.0 /usr/lib/libcurl.so.4.0.0
/usr/lib/libcurl-openssl-1.0.so /usr/lib/libcurl.so.4.1.0
/usr/lib/libcurl-openssl-1.0.so.4.4.0 /usr/lib/libcurl.so.4.2.0
/usr/lib/libcurl.so /usr/lib/libcurl.so.4.3.0
/usr/lib/libcurl.so.3 /usr/lib/libcurl.so.4.4.0
/usr/lib/libcurl.so.4

/usr/lib/libcurl-openssl-1.0:
libcurl.so libcurl.so.4 libcurl.so.4.4.0


#5

Finally solved!

Just removed the LD_PRELOAD flag (yeah, thats right) and now is working flawlessly. I messed around with lots of libs and LD_PRELOAD flags, without success!

THE KRAKEN IS ALIVE!!!

PS: Running ANY LD_PRELOAD will result in a seg fault.


#6

Can’t believe I forgot this thread until you reply. Anyway, glad it worked out for ya!


#7

Ty for your time!


#8

Hm, I’m sorry, but I’ve been facing the same problem as yours, although I don’t know how to remove the LD_PRELOAD flag. Would you mind teaching me how to do it, please?

I would appreciate it very much :slight_smile:


#9

Just edit the file at /bin/gitkraken or something like that.


#11

Thanks, it’s worked now :slight_smile:


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.