Trying to install Cubocore Linux on 32bit UEFI

I tried your with MX linux but mx linux doesn't seem to boot on UEFI32. Then I tried to copy the files needed to make it boot on uefi32 and tried to paste it on Cubocore Linux usb and it is read only.

Can you advice how did you get it to boot? I have Linx 10 with windows 8.1 I tried to make it boot from USB using MX Linux but that didn't work either.
Sorry: I missed the rufus part. I used Etcher. My bad

Now I am getting into the grub rescue mode. :frowning:
What I have done so far.
Flashed Cubocore img to USB using Unetbootin, with fat32 format.
Copied the 32 efi and the folder to the correct location.
Tried to boot and its stuck on grub rescue mode.
When I ls all the partition mentioned all are unkown filesystem.

What am I doing wrong here?

Thanks.

1 Like

Well that is progress. Are you seeing the grub menu ever or just grub rescue? If you never see the grub menu, then the donor bootia32.efi is wrong and I need to find a different donor bootia32.efi. Here is the bootia32.efi that I've been using. If this one works for you, I'll need to update my instructions!

2 Likes

Actually I tried the MXlinux first which never worked inthe first place. Then I tried Manjaro32 and it worked then I tried using Manjaro32 as donor for bootia32.efi

I will try you donor efi and get back to you. Thanks for the quick response.

1 Like

Yeah, if the Manjaro bootia32.efi could read FAT32, then that one would have worked, but it can only read ISO9960 (read-only) format. Weird that MX-Linux was a no go.

2 Likes

This efi worked for me.. Thanks alot.

2 Likes

Just to summarise the steps I followed.
Step 1: Format USB Stick with Fat32.
Step 2: Flash Manjaro ISO using Unetbootin only. Reason: This will not make the usb read only.
Step 3: Copy the bootia32.efi from this Link to /efi/boot/
Step 4: i386-efi directory to /boot/grub/
Step 5: Insert USB Stick to the UEFI32 Device and Boot.

Hope these are much clear steps. I have tested this on my Linx 10 Tablet which is Intel Atom Processor capable of 64Bit but UEFI is 32Bit.

:no_entry: Do not install Manjaro using this method yet. As calamares fails to install efi partition for uefi32. :no_entry:

1 Like

Hey.
I want to know how did you install.efi parition?

I followed your method as mentioned in one of your post but it ends with error.

Error image. Screenshotted Image on special request :stuck_out_tongue:

Later i tried efibootmgr and already tried re installing grub. Still boot fails and my device entry grub rescue mode.

Librewish tried everything to help me with it but maybe we were having a bad day when we tried installing it on my linx 10 tablet device.

Any advice to solve this is highly appreciated.

The screenshot app for KDE is called Spectacle. :wink:

I didn't do anything special. My device (a 2-in-1 laptop) had the ESP partition (/boot/efi) already defined. My system has an SD card which Calamares often presumes is the main drive (BIOS issue actually.) I have to explicitly check the drive assignments before installing or it will try to put the bootstrap on the SD card. On my system, that is fatal because the SD card is not enabled at boot time.

what does efibootmgr -v show? Also

lsblk

Lol yes. This was when we were doing some live testing for cubocore.

Version 16.

I can see 3 Partition in my MMC of 32GB.
300mb
24GB - brtfs
4gb swap.

I wanted to see whole output of the terminal command eifbootmgr -v. Likewise the whole output of lsblk. If your device behaves like mine, then I want to make sure that there is only one mmc device...

From what you've shared, it suggests that the main drive was wiped. I'm guessing that the 300mb partition is supposed to be the ESP partition. It should be FAT32 or vfat with the boot flag set. It should be mounted at /efi/boot during installation.

This just responds with Version 16, nothing else.

While lsblk output is full list of drives Out of which the eMMC is the one that had windows which I partitioned using the calamares installer. I am just away from the device now. Will get back with detail output.

OK, that's a clue. Ordinarily efibootmgr -v would report the boot entries and boot order of the BIOS.

When you get to the device

blkid

will be more helpful if there is only one eMMC device showing in lsblk.

lsblk
NAME         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0          7:0    0   8.5M  1 loop /run/miso/sfs/livefs
loop1          7:1    0  93.7M  1 loop /run/miso/sfs/mhwdfs
loop2          7:2    0   1.1G  1 loop /run/miso/sfs/desktopfs
loop3          7:3    0 562.1M  1 loop /run/miso/sfs/rootfs
sda            8:0    1  14.6G  0 disk 
└─sda1         8:1    1  14.6G  0 part /run/miso/bootmnt
mmcblk1      179:0    0  29.1G  0 disk 
├─mmcblk1p1  179:1    0   300M  0 part 
├─mmcblk1p2  179:2    0  24.7G  0 part 
└─mmcblk1p3  179:3    0   4.1G  0 part [SWAP]
mmcblk1boot0 179:8    0     4M  1 disk 
mmcblk1boot1 179:16   0     4M  1 disk 
zram0        253:0    0   481M  0 disk [SWAP]
blkid
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/mmcblk1p1: UUID="0B18-24C7" TYPE="vfat" PARTUUID="b31b0e7d-37a7-4840-b818-c25498ac448e"
/dev/mmcblk1p2: UUID="9e94c743-408a-4795-8e81-17993a0e6175" UUID_SUB="a06fa888-e61b-46a2-bd95-6da82b4980d7" TYPE="btrfs" PARTUUID="eb89b573-d0d5-4a98-afb5-4184131cd57a"
/dev/mmcblk1p3: UUID="517aa750-f0bd-4fa9-94b4-5b729cd84e7c" TYPE="swap" PARTUUID="8d88d9e5-35d4-409e-82b3-757340892bde"
/dev/sda1: LABEL="MJROROLL" UUID="6403-9E9E" TYPE="vfat" PARTUUID="0880dd0a-01"
/dev/zram0: UUID="be9a1a92-9dda-4130-af27-785a53fedb7c" TYPE="swap"
efibootmgr -v
BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0003,0002,0001,0004,0005
Boot0001* UEFI:CD/DVD Drive     BBS(129,,0x0)
Boot0002* UEFI: Built-in EFI Shell      VenMedia(5023b95c-db26-429b-a648-bd47664c8012)..BO
Boot0003* UEFI: SanDisk PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/USB(3,0)/HD(1,MBR,0x880dd0a,0x800,0x1d2d000)..BO
Boot0004* UEFI:Removable Device BBS(130,,0x0)
Boot0005* UEFI:Network Device   BBS(131,,0x0)
fdisk
Disk /dev/mmcblk1: 29.12 GiB, 31268536320 bytes, 61071360 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 4C326E79-BD3D-4097-B38C-9F5E5D100439

Device            Start      End  Sectors  Size Type
/dev/mmcblk1p1     4096   618495   614400  300M EFI System
/dev/mmcblk1p2   618496 52394219 51775724 24.7G Linux filesystem
/dev/mmcblk1p3 52394220 61063064  8668845  4.1G Linux swap

The partitions look good. The boot order looks a little busy (but OK.) Based on what I see, no boot entry is pointing to mmcblk1p1.

As best as I can tell, the state of the machine is that the install succeeded except for installing grub. You should be able to chroot (manjaro-chroot -a) from the liveUSB into Cubocore and then grub-install might just work there. You might have to mount mmcblk1p1 as /boot/efi After chrooting you can check what's mounted with lsblk.

Something to check in the chroot would be the /etc/fstab. If all three partitions are listed (ESP, root, and swap) then the last thing to do would be update-grub. If grub-install and the update-grub worked, you should be able to boot after exiting the chroot. I don't know if you'd have to regenerate initramfs (sudo mkinitcpio -P) first before updating grub, I never had to, but... YMMV

Edit: If grub-install succeeds, it will "fix" the boot order and add an entry for manjaro to the boot table.

I have tried to chroot and try to install grub but that fails with something like 'efi partition does not exist'

Update grub works.

Will look into the fstab and see what's there.
After the installation when I boot into liveusb grub and try to detect bootloader I can see 3 selections and all of them Throws error.
'error : not a valid root device. '

Let me try fstab.

Forum kindly sponsored by Bytemark