Trying to get Telepathy to work getting self signed certificate error

I installed telepathy from AUR git and removed the Official Repo telepathy packages.

Now when I sign into a google account for instant messaging and Google Hangouts i get the
following. There are 2 screenshots. One with the initial error and the 2nd with the details.

When i click continue and ultimately accept this self signed cert telepathy just hangs on connecting. At least now i am getting a certificate issue and I’m hoping someone can help me resolve this issue.

I’m really trying to get this working, I have tried 3 different distributions and weeks trying. If anyone can help i would be most grateful!

I see that no one responds to my posts about “telepathy”. This here is my 2nd post. The other being: KDE Instant Messaging signond not working with Google, Skype Lync

With the almost instant responses from moderators from my other questions posted here (which is remarkable in and of itself) I have to assume there is something a miss with this “telepathy” software and no one knows really how to fix it.

I have been going round and round with KDE bugs, KDE Neon forum, and Reddit and tried several distros and have yet to find a solution or a fully working Telepathy/Instant Messaging. It doesn’t work on any distro with KDE as the GUI.

I also see this is an ongoing on and off issue that seems to run all the way back to 2015. I have dug through Google searches and found very similar issues spread out over several years.

I will have to put it to rest because I have no further ideas and have found no solutions.

I did see one of the moderators on said its the signond package which is fixed in “Upstream” and closed all the bug reports related to this subject but I have no idea how to implement this so…

Its a shame this doesn’t work since this service is super useful for someone who uses several messaging services and several accounts for each service…

There is a software package called “Franz” that works to replace this KDE embedded instant messaging service but it only allows for 3 accounts and you have to create an account with Franz then add your Google, Skype, etc accounts. If you want more then 3 accounts you have to pay money to Franz… I guess for now this is the only workaround I can find.

If anyone does find a solution please let me know. I wold love to get this working and have spent way to many hours days and weeks trying.