Trying to flash LineageOS on my old Samsung Galaxy S6

#1

Hi, I'm trying to install LineageOS on my old Samsung Galaxy S6 on which I have enabled developer options and USB debugging.

I tried to do this at beginning of year and posted some questions Best application to flash my old SGS6

I did get good feedback from @Lolix, @linux-aarhus and @torvic but unfortunately I couldn't move forward due to other circumstances which prevented me from devoting the time required at the time.

So I have tried to make a start again...

I'm posting this under "Newbie Corner" as I need step-by-step help, but not sure if this is the correct forum to be honest as it is not related to Manjaro itself. Please advise if this is not correct....

What I have installed so far on my old SONY VAIO Manjaro laptop is...

https://wiki.lineageos.org/adb_fastboot_guide.html # Installed adb and fastboot

"platform-tools_r28.0.2-linux.zip" # download, extract & configure # done

Setting up "adb" # done, I can see "List of devices" when phone connected

Was able to boot phone into recovery mode, "Android Recovery" text only menu is displayed. I was not able to select and "Reboot to bootloader".

Was able to boot phone into "Download-mode" showing "ODIN MODE" top LH of text only screen

I have also installed following software on my laptop...

$ sudo pacman -Syu android-udev			# installed OK

$ pamac build heimdall				# installed OK

$ sudo heimdall print-pit			# this produced a long list of partitions, then 
						# phone reboots to standard home screen.

$ sudo pacman -Syu android-tools		# I decided to install this from stardard repos
						# I wasn't sure if this was required or not.

I wasn't sure if my phone needed to be rooted, so tried to root my phone following these instructions...
https://www.all-things-android.com/content/how-root-samsung-mobile-device

I was able to complete each step successfully until step 22.

.. I just didn't get "Flash completed successfully!" message next to the progress bar at Step 22 of instructions.

I did get following message in the Status text area....

Heimdall v1.4.2

Copyright (c) 2010-2017 Benjamin Dobell, Glass Echidna
http://www.glassechidna.com.au/

This software is provided free of charge. Copying and redistribution is
encouraged.

If you appreciate this software and you would like to support future
development please consider donating:
http://www.glassechidna.com.au/donate/

Initialising connection...
Detecting device...
Claiming interface...
Setting up interface...

Beginning session...
Releasing device interface...

Not sure what went wrong here to be honest.

NOTE: Phone is still not rooted yet. is this a problem going foward?

I'm trying to follow the instructions laid out on...

https://wiki.lineageos.org/devices/zerofltexx/

when I click on the first link...

Installation
How to install LineageOS on the Samsung Galaxy S6

I get to this page....

Install LineageOS on zerofltexx
https://wiki.lineageos.org/devices/zerofltexx/install

TABLE OF CONTENTS

  1. Basic requirements # DONE
  2. Preparing for installation # DONE
  3. Installing a custom recovery using heimdall # I'M HERE
  4. Installing LineageOS from recovery
  5. Get assistance

"Installing a custom recovery using heimdall" states the following instructions....

Download a custom recovery - you can download TWRP. https://dl.twrp.me/zeroflte/ Simply download the latest recovery file, named something like twrp-x.x.x-x-zerofltexx.img.

NOTE: I found "twrp-3.2.3-0-zeroflte.img" 24.8M 2018-08-04 13:04:34 EDT

which is different from "twrp-x.x.x-x-zerofltexx.img"

Power off the your device and connect the USB adapter to the computer (but not to the device, yet).

Boot into download mode: With the device powered off, hold Volume Down + Home + Power.

Accept the disclaimer, then insert the USB cable into the device.

On the computer, open a command prompt (on Windows) or terminal (on Linux or macOS) window in the directory the recovery image is located, and type:

heimdall flash --RECOVERY twrp-x.x.x-x-zerofltexx.img --no-reboot

so I think my command should be...

$ heimdall flash --RECOVERY twrp-3.2.3-0-zeroflte.img --no-reboot

NOTE: I haven't done this step yet because the next step is...

Installing LineageOS from recovery
Build a LineageOS install package.

which links to https://wiki.lineageos.org/devices/zerofltexx/build

where it talks about "Build LineageOS and LineageOS Recovery"

this looks very complicated for my limited knowledge of Linux and Android flashing etc.

I'm wondering:

Is there an easier way to do this ?

Have I installed the correct software packages so far?

Any help / guidance would be appreciated. Thanks.

Sorry for long post, I'm trying to provide as much info as possible.

split this topic #2

2 posts were merged into an existing topic: Best application to flash my old SGS6

closed #3