Trouble with Xbox one controller

Hello everyone. So I’ve been working on making the switch from Windows to Linux on my computer. I’ve been using it for a couple of months and things have been working pretty well. I paired my Xbox one controller over bluetooth and it’s been working great!

Yesterday, I decided to hop over to Windows because I wanted to play Destiny 2. I paired my controller using the Xbox wireless dongle and played for a couple of hours (for some reason my games get really bad stuttering in Windows when using the controller over bluetooth). I rebooted back to Manjaro and repaired my controller over bluetooth. But now it won’t work correctly. It pairs, and the games recognize that I have a controller connected. However, the right stick isn’t working properly and a couple of other buttons aren’t being properly recognized either. I’ve tried deleting and repairing controller several times. I’ve also tried shutting the computer down and rebooting several times. How do I fix this?

Controller does work in wired mode. So it’s just the bluetooth wireless that isn’t working properly.

I fixed this. I was had to install the kernel headers for 5.15. Then rebooted and installed the xpad driver from the AUR. Now it is working fine over bluetooth. Not sure why it worked before that without xpad installed, but everything seems to be fine now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.