Trouble with the proprietary Nvidia drivers after switch to AMD CPU


So I think this problem is quite common as I’ve seen a lot of similar posts. I tried a few things over the months, but nothing that solved it. (It’s been so sparse that I did not record everything I tried)

I’ve been running a system with Manjaro Gnome and other Gnome flavored distributions (mainly Ubuntu) for years with everything working flawlessly with the following system:

  • Intel i7 4770
  • Nvidia GTX 770

A few months ago I had to change the CPU: I replaced it with an AMD Ryzen 7 3700x. (I reinstalled the OS many times after this).

In this new configuration, some observations (same on the gnome flavors of Ubuntu and Pop!_OS):

  • Works great with the nouveau driver, but can’t use my GPU for games or OpenCL.
  • Very laggy (unusable) with the proprietary driver (tried version 460 as suggested by mhwd, but also 450, 440 and 390). Crashes ~30% of the time in the first 2 minutes after launching the gnome session. (Alt+SysRq not doing anything, have to pull the plug). I get the same on Xorg on or Wayland. On the plus side the proprietary drivers also allow to e.g. run games (minus periodic glitches in the sound and in the image).

This is the output of inxi --admin --verbosity=7 --filter --no-host --width:

journalctl has a lot of entries like these:
(II) event15 - Logitech Gaming Mouse G300: SYN_DROPPED event - some input events have been lost.
(EE) client bug: timer event15 debounce: scheduled expiry is in the past (-36ms), your system is too slow

Would you have an idea of what to try next? I can run tests, re-install the OS, etc.

Thanks a lot for your help and for this amazing distribution in general.

O.K. my honest opinion:
Avoid NVIDIA and replace it with e.g. ASUS Radeon RX5700 XT TUF 3 EVO GAMING-
or MSI RX5500 8GB (cheaper) - this is the combination I use.

Ha! That was indeed my intention when the problems started to appear …then I realized how high the GPU prices are these days.
I don’t have the money right now, but I will definitely make the switch when I can :slight_smile:

Hi @lithiumw ,
Welcome to the forum, I wish whether you can solve your problem reading this post.

I think that @Mirdarthos and @stephane comments could be helpful.

Hope this help, regards

Hi @j8a and @GaVenga

After an extra week of frustration I ended up buying an older AMD card off the second hand market. It’s amazing with the open source driver, but can’t get OpenCL to work yet. But that’s for another thread if I can’t figure it out in a few days!

Thanks for your replies

I also replace my Intel CPU with AMD Ryzen 7 5800x recently with NVIDIA proprietary driver. The system booted without any issue, only the VirtualBox VM was messed up, probably due to different virtualisation technology. What kernel do you use? Mine is 5.10.

Hi @dobedobedo

So no crashes for you? That’s great! Are you using the gnome flavor too? I don’t know about the virtualization, but the kernels I have used since changing CPU were 5.4, 5.10 and now 5.12.

I ran a Fedora box recently (amd cpu + nvidia) without problem. What’s going wrong with yours?

I use KDE Plasma. Before I boot into the system after replacing the CPU, I use Live Media to chroot to it and upgrade it because the system had not been maintained for more than a year. After that, it runs smoothly.
My VM’s problem is out of my knowledge. It is fucked beyond recognition so that I don’t even know how to investigate the problem. I just removed it and created a new one. It’s for MS-office and other Windows applications anyway so no important data inside.