Trouble with IWD after update

Hey there,
I just installed Manjaro-Arm minimal on my Pinebook Pro. Then I managed to set up iwd so that wifi worked (Presumably Ethernet as well, because the status lights were blinking). After that and some more stuff I updated my system (including some update to linux: 5.17.1-4 > 5.1.5-4). Now IWD refuses to start - I get the same error as this guy, but he is apparently using void-linux.
This must be related to the kernel version, but there is apparently no way to downgrade that.
What do I do now? I don’t want to reinstall and void all my progress, though I also can’t restore a backup.

Hm, the only kernel config we are missing from that list is CONFIG_KEY_DH_OPERATIONS and that seems to only be needed for WPS support. Although a couple of the options are only modules…

This list: gettingstarted [Wiki]

I decided to put my pacman log here so you might be able to trace the problem back to something: termbin(dot)com/nwy58

I am just out of ideas. I tried to install networkManager, which worked after manually downloading all the depends, but it also just refuses to detect any network connections. There were no errors in journalctl or anywhere else.

Is your SSID being broadcast on a channel above 11? because then the PBP might not be able to see it, until you set your country code with crda.

I gave up on Wifi and tried Ethernet - I don’t think these have SSIDs, do they?

They don’t, no. They should be configured using systemd-networkd or NetworkManager automatically.

This is exactly, what is not working. Weird stuff.