Trouble installing Manjaro on emachines W3623 computer

Okay, like this?..

menuentry ‘Manjaro Linux (Kernel: 4.14.68-1-MANJARO x64)’ --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-4.14.68-1-MANJARO x64-advanced-370c0f2a-1349-4663-b5b8-cb86c303ff07’ {
savedefault
load_video
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root=‘hd0,msdos1’
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 370c0f2a-1349-4663-b5b8-cb86c303ff07
else
search --no-floppy --fs-uuid --set=root 370c0f2a-1349-4663-b5b8-cb86c303ff07
fi
echo ‘Loading Linux 4.14.68-1-MANJARO x64 …’
linux /boot/vmlinuz-4.14-x86_64 root=UUID=370c0f2a-1349-4663-b5b8-cb86c303ff07 rw quiet resume=UUID=952de4bd-bf89-4d71-817f-de515faf1828
echo ‘Loading initial ramdisk …’
initrd /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
}

Yes. Now I need the rest…

put output bewteen the (```) and (```)
If you don’t understand (who can?), it’s okay. continue without disruption.

And this I need to do from the live cd correct?

No, get all this NOT from the livecd OS
but from the installed OS. Using livecd grub
Boot into it following my link, You have done it before.
The search.file… root … configfile method.
Boot into installed OS and get the information from its terminal.

Oh okay already here. Give me a sec…

Here is the link. Again.

Yes, I got that.

So I’m getting this error message…

’ ’ ’
sudo parted -l
[sudo] password for rummy1:
Model: ATA WDC WD1003FZEX-0 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 993GB 993GB primary ext4
2 993GB 1000GB 6981MB extended
5 993GB 1000GB 6980MB logical linux-swap(v1)

Warning: Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0
has been opened read-only.
Error: Can’t have a partition outside the disk!
Ignore/Cancel?
’ ’ ’

What do I do?

Ignore.
Now go to the next command/output,
And continue to the next one if any error.
Print error.
And next one and so on.

How do I ignore?
Edit: nvm I used a capital instead of lowercase

Type ignor
cancel is also fine.
Type anything. Doesn’t matter.
.
.
.
.
.

Jumping real far ahead… (maybe I shouldn’t?)

When starting up computer and then whn presented with manjaro grub.
At manjaro entry type ‘e’ and arrow down to linux line.
Backspace to remove “resume=UUID=952de4bd-bf89-4d71-817f-de515faf1828”
and boot using F10 or ‘alt’ +’ ‘x’

Reason: your swap is the first/only logical partition (sda5) in your extended partition (sda2).

A good question: why doesn’t debian have this problem?
Question back: does debian boot?
Does debian have this resume=UUID=xxxxxxxxxx in its grub.cfg?

I had typed in ‘Ignore’ instead of ‘ignore’.

Okay I typed all of that in (the rest without a hitch).

What now?

Print out for us.

’ ’ ’
efibootmgr -v
EFI variables are not supported on this system.
’ ’ ’
’ ’ ’
sudo parted -l
[sudo] password for rummy1:
Model: ATA WDC WD1003FZEX-0 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 993GB 993GB primary ext4
2 993GB 1000GB 6981MB extended
5 993GB 1000GB 6980MB logical linux-swap(v1)

Warning: Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0
has been opened read-only.
Error: Can’t have a partition outside the disk!
Ignore/Cancel?
Ignore/Cancel? Ignore
Error: Can’t have a partition outside the disk!
Ignore/Cancel? I
Error: Can’t have a partition outside the disk!
Ignore/Cancel? Ignore
Error: Can’t have a partition outside the disk!
Ignore/Cancel? ignore
Model: TSSTcorp CD/DVDW TS-H652D (scsi)
Disk /dev/sr0: 2160MB
Sector size (logical/physical): 2048B/2048B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 131kB 8622MB 8622MB primary boot
2 8622MB 8639MB 16.8MB primary esp
’ ’ ’
’ ’ ’
sudo blkid
[sudo] password for rummy1:
/dev/sda1: UUID=“370c0f2a-1349-4663-b5b8-cb86c303ff07” TYPE=“ext4” PARTUUID=“55cfc2af-01”
/dev/sda5: UUID=“952de4bd-bf89-4d71-817f-de515faf1828” TYPE=“swap” PARTUUID=“55cfc2af-05”
/dev/sr0: UUID=“2018-08-18-15-33-20-00” LABEL=“MJR17112” TYPE=“iso9660” PTTYPE=“dos”
’ ’ ’
’ ’ ’
findmnt -s
TARGET SOURCE FSTYPE OPTIONS
/ UUID=370c0f2a-1349-4663-b5b8-cb86c303ff07 ext4 defaults,noatime
swap UUID=952de4bd-bf89-4d71-817f-de515faf1828 swap defaults,noatime
’ ’ ’
’ ’ ’
findmnt /boot/efi
’ ’ ’

okay!
Now at this installed OS terminal
Do this…

sudo grub-install /dev/sda
sudo update-grub

Reboot without livecd usb.
If you are given the manjaro grub menu…

Boot up.
If any error at boot, say… ‘hibernation file not specified’ but continues booting up (sucessfully).
Please don’t say ‘it doesn’t work’ or ‘fail’
Please say…

It boots up but there is an error message but I too quik to notice.

Okay just to show the first part…

’ ’ ’
sudo grub-install /dev/sda
[sudo] password for rummy1:
Installing for i386-pc platform.
Installation finished. No error reported.
’ ’ ’
’ ’ ’
sudo update-grub
Generating grub configuration file …
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
’ ’ ’
Is this correct?

Correct.
Good. Reboot.

I’m getting the error

‘ ‘ ‘
No bootable device — insert boot disk and press any key
‘ ‘ ‘

Okay. Understand.
Now don’t go removing manjaro or install debian.
Stop.
I’ll continue real soon here at this post.
Or the next one to get your attention.

Okay glad it wasn’t just me messing it up. Never get emachines computers. They are terrible haha

Boot up again to the installed OS using livecd grub (my link)
search.file xxxxxx root
configfile…

.
.
.

  1. Open up /etc/default/grub
    remove “resume=UUID=xxxxxxxxxxxxxxxxx”
    in one of the lines
    save file.

  2. open up /etc/mkinitcpio.conf
    at HOOKS line, remove ‘resume’ & ‘udev’ and (if you have) ‘usr’ and ‘lvm2’
    Add ‘systemd’ to this HOOKS line so it looks like
    HOOKS=“base systemd block autodetect modconf keyboard keymap plymouth filesystems fsck”
    note ‘systemd’ is 2nd, after ‘base’
    save file

  3. At terminal

sudo update-grub
sudo mkinitcpio -P

Reboot without livecd usb.
Let us know.
Good luck.

ps: I’m going away for a short while, like an hour or so.
ps: @AgentS, any input? Appreciate any. :slightly_smiling_face:

@rummy1, when I’m away, please follow petsam. I’d listen to him.