Trouble installing Manjaro KDE 21.1.6 on Acer Nitro AN515-52

Ok, here goes my story about the hell I had these last three days trying to dual-boot between Manjaro 21.1.6 and Windows 11.
It all started 3 days ago when I put Manjaro on my USB stick on Windows using YUMI, I decided to use this program because I had previously tried with several others to see which one worked just to boot from it, to my surprise, when I entered the stick and tried to install Manjaro using the graphical interface I found the following error failed to unpack image /run/miso/bootmnt/manjaro/x86_64/rootfs. fs, no problem, I went to sleep and the next day I tried with other programs to burn the ISO on my USB stick, because if I understood correctly, the problem was in the search of the rootfs.fs file in the manjaro/... directory, that in the root of my USB stick only had a multiboot/... directory, so I tried with UNetbootin but when booting from the USB stick I got to unknow filesystem, grub rescue.
When it doesn’t give me any problem it is because the USB stick directly is not shown in the BIOS to boot from it, something that happens to me for example with Rufus.


  • My flash drives are always in fat32 and GPT, I’ve tried with 3 different ones
  • Secureboot is disabled
  • The Sata mode is set to AHCI
  • Fastboot is disabled
  • I used QuickHash to check the ISO, everything ok

Details about my system:

  • System Model: Nitro AN515-52
    BIOS: V1.28 (type: UEFI)
1 Like

I think thats why many people recommend programs like Rufus or Balena Etcher,even now Ventoy is gaining terrain and many people like it for the simplicity of use.

I’ve tried BalenaEtcher and Rufus (that last one I mentioned before), no luck with either, but I’m going to check with Ventoy and see how it goes.

Well, Ventoy worked, or so it seems, the installation finished fine but when I turn on the computer it boots directly into Windows, no GRUB menu. I thought it has to do with the fact that I am installing Manjaro on a secondary disk where I have two partitions, one to store Windows stuff and the other where I want to install Manjaro, but during the installation process I made sure that the boot loader is installed on the correct disk (the primary one where I have Windows installed). Now I still have to figure out how to make the GRUB menu show up with both operating systems.

Edit 2:
Manjaro doesn’t show up as an item on bios boot priority order list.

I’m wondering,your computer is set to UEFI or Legacy? If it doesn’t appear I suspect is because it was installed as UEFI and your computer is maybe set to Legacy.
Though I don’t have much experience about partitions and boot loaders (I just install Manjaro in one disk and erase all).

There is no hell - only expectations not met. This is not a bug.

There is a lot of tools which can write the Manjaro ISO to a stick but ISO unpackers cannot. The tools listed below usually works.

  • dd (Linux)
  • ventoy (Windows, Manjaro)
  • Rufus (Windows)
  • popsicle (Manjaro)
  • mintstick (Manjaro)
  • imagewriter (Manjaro)
  • isousb (Manjaro)
  • Balena Etcher (Windows, Manjaro) - not recommended but usually works

If you boot your system with Legacy boot enabled the ISO - Legacy boot will most likely be the default and Manjaro will boot in Legacy mode and your trouble begin.

Always install using the same method for all systems.
Disable Legacy boot in the firmware - it is often enabled and will boot Manjaro in BIOS mode.

You cannot - BIOS based grub cannot show EFI based system

You have two options - I suggest you use the first as this is the least trouble

  1. Use your firmware boot override
  2. Reinstall Manjaro in EFI mode