Trouble connecting Google account

Hi, I’m new, and I need to connect to my Google account through the online accounts menu to connect my Google Drive, but every time I click on the Google button, it opened the window, I can scroll just fine, but I can’t type, the problem didn’t occur for any other accounts option (e.g., Microsoft).

I join the discussion of the problem. I also can’t log in to my Google account. University account: st****** , a black screen appears and nothing else. The main account is logged in without any problems:

+1 for me as well.

has any one seen this or able to solve this. This is very annoying. the other email providers are working fine but google.

Appreciate any good tip here.


While I was testing something on a clean VM with gnome installed I tried to replicate this issue. From what I can tell the window loads a web page, so if the window stay’s black, the page won’t load correctly. On a clean install I can get the window to load so it seems the machines behaving this way cannot connect to the page. I’ll try to find some info to see if this is easily testable outside the window.

Edit: the window opens connections to

Are you blocked in some way from accessing these sites?
I wanted to try out portmaster by safing for a while and this was a good usecase, nice tool!

I tried to ping these services - all packages pass correctly

Thanks for coming back @Hanzel , for me as well neither are blocked, can lookup and access on browser smoothly.

Thanks for pointing that @Hanzel .

Following that link and after some digging, I can confirm that, after below steps, I am able to add new google account.

Here’s what I tried

  1. add nvidia-drm.modeset=1 to GRUB_CMDLINE_LINUX_DEFAULT

  2. and then regenerate grub using below command

grub-mkconfig -o /boot/grub/grub.cfg
  1. and then reboot the machine.

  2. once rebooted back, run this command from CLI (choose your variant apprpriately)



and add your google details.

I hope this helps.


thank you very much, i am new to linux and this got me some trouble, but your solution helped me