Trouble adding andontie-AUR key

When executing
sudo pacman-key --refresh-keys
I receive this error
gpg: refreshing 142 keys from hkps://
gpg: keyserver refresh failed: General error
==> ERROR: A specified local key could not be updated from a keyserver.

But it happens too when receiving keys with

pacman-key --recv-key EA50C866329648EE
that happens the same
gpg: keyserver receive failed: General error
==> ERROR: Remote key not fetched correctly from keyserver.
How to fix please?


sudo pacman-key --refresh-keys --keyserver hkps://

Did you follow the instructions?

HELP! I can’t add your key! There’s been some issues lately that people have addding my and other keys to their Arch keyring. If you run into this proablem, you need to manually add a keyserver in your Pacman GPG config file - The Arch Wiki explains how to do this.

it works for refreshing keys, but the error is here too.
And If I put the second command(for receiving keys) it will fail again at the same way

yes I follow the instructions, but andontie problem is for every key, not only andontie, the packager I think is having others problems but not mine

gpg: public key CF66D153D884358F is 16 seconds newer than the signature
gpg: depth: 0 valid: 1 signed: 73 trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1 valid: 73 signed: 83 trust: 4-, 0q, 0n, 69m, 0f, 0u
gpg: depth: 2 valid: 73 signed: 26 trust: 73-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2020-12-03
==> ERROR: A specified local key could not be updated from a keyserver.

the final output is her. And if I wanna get keys I can not because of this error

What’s the output of the following:

cat /etc/pacman.d/gnupg/gpg.conf
cat ~/.gnupg/gpg.conf

keyserver-options timeout=10
keyserver-options import-clean
keyserver-options no-self-sigs-only

cat: /home/albertogm/.gnupg/gpg.conf: No such file or directory

cat: /root/.gnupg/gpg.conf: No such file or directory

keyserver hkp://
in gpg.conf let me receive keys( it is in the archlinux wiki) and refreshing keys but the error is here for all hkps so I think is a workaround not a fix…

Putting this order in console is giving me ALWAYS error in the final step, but it appear to function " more or less"

But, anyways, if I want to receive a key, it’s impossible without editting the gpg.conf