Tried making a bootable usb with 4 programs. They all didn't work

Hello, I tried making a bootable USB with Manjaro on it but I couldn’t boot from the USB.
I tried to make the USB bootable with 4 programs: Yumi, UUI, Rufus and Unetbooting.

When trying to create a bootable USB with 2 of the programs they just unallocated 16GB on the USB and then used 4MB for an EFI boot folder?

After using the 2 other programs I got a little further and I could see all files were on the USB.
But when trying to boot I either got the message:

error: unknown filesystem
Entering recue mode…
grub rescue>

Or I got the message saying: An operating system wasn’t found.
I’ll try again tomorrow but I thought maybe you guys have some idea of why this easy thing just isn’t working for me xD

Assuming you are on Windows - use Balena Etcher it is simply the best when it comes to writing Linux ISOs. Rufus is mainly for Windows.
Finally ensure secure boot is turned off in BIOS if you want to boot Manjaro.

That is normal - Windows cannot read the content of the ISO.

Many popular tools unpack the ISO and write the files to the stick - this will not work with Manjaro ISO.

With Rufus on Windows - don’t change any option - except for the ISO and target - ignore that you cannot read the content of the partition - it usually works.

Balena Etcher can do the same thing - just write the ISO bit-to-bit.

Another tool you can try is ventoy - it is even simpler - after running the preparation tool - you simply drag the ISO onto the empty space of your USB and the ventoy boot partition will take take of loading the ISO.

1 Like