Tried installing KDE (dual Boot Windows) after having used XFCE for a few days. No boot drive found, please help

Hi, I usually don’t ask for help but it’s getting nowhere. I’m a Linux noob discovering a whole new world.

A few days ago, I followed this dual boot guide (forum manjaro org/t/root-tip-dual-boot-manjaro-and-windows/1164) (using Windows until I’m settled in a Linux distro) to install Manjaro XFCE as second OS without a problem. Only issues I ran into were a few minor problems I could fix relativily easily.

Today, I wanted to change things up and install KDE as I like to customise whatever is possible. I’ve read in another post that doing a clean install was the easiest way (I’ve also checked the Manjaro docu page about installing desktop environments).

I have 2 storage drives, an M.2 which I use for Windows, and a separate clean SSD for Linux, or at least partly.

The steps I took:

  1. Go into BIOS to change my boot order and make Windows the priority again.

  2. Boot into Windows and remove all partitions to make the SDD “clean” again.

  3. Follow the guide I mentioned above again, but this time with KDE on the bootable.

  4. Manually partitioned the drive as mentioned in the guide. Here I noticed that my SSD already had a small partition of approx 100MB, which I could not see in Windows Disk Manager.

  5. Complete the steps from the guide (including the check for my bootorder).

  6. My PC booted again in Windows, so I followed the additional steps.

  7. Last resort, I followed the steps in this guide (archived forum manjaro org/t/using-livecd-v17-0-1-and-above-as-grub-to-boot-os-with-broken-bootloader/24916).

At this moment, after spending quite some hours to fix this after a long day at work, my hope is reaching out to people with experience with this OS.

If further information is needed, feel free to ask. All help is appreciated!

Steps I took the next day, guided by some redittors:

I installed EasyUEFI to see if something actually happened and this was the result:
i imgur com/0hUdrss.png

To follow up, I used MiniTool Partition Wizard to completely erase my SSD. I plugged out my M.2 drive and installed again. This didn’t result in anything better, my PC booted with the bootable USB again. BIOS doesn’t show Manjaro as a boot option.
I then reinstalled my M.2 drive with Windows on, went to check with EasyUEFI to find this:
i imgur com/OcMrwhc.png

I’m getting clueless at this point about how to fix this. Would rEFInd help with this issue or does someone know where I mess up?

According to this picture:

It is there, but hidden… No idea… does it mean is flagged as hidden? If so, then it is a bad idea. Only boot/esp is needed for the efi partition.

sudo parted -l

I see only windows tools… no idea about them… on linux you should use parted, grub (or any other boot loader) and efibootmgr …

I suppose it is flagged, although I can’t find any way to make it visible/normal again. I just had a desperate attempt installing rEFInd resulting in the following:
i imgur com/1ZJoxX5.png

What steps could I take if I manage to boot Manjaro by using grub from the bootable USB?

Use gparted/kparted on a live session of manjaro and change the flag there :wink:

1 Like

You sparked new hope, will try it in an hour!

I’m a Noob at linux as well. I ran into a similar issue as you did starting up. My solution ended up amounting to me using an android phone to make a bootable usb with an app called “EtchDroid” and a standard USB adapter (8-16 gig should work). Then booted my pc with the USB from my bios. Went through the initial set up and installed GParted. If you have any questions just hit me back.

What probably happened is this, your second install created a 2nd directory as EFI partition, Your first one contains the original EFI files from your first install which didn’t get updated. These EFI files probably point to the 2nd install. However, the Manjaro installer should be used to start over with a new install allowing it to erase the drive. This will allow the proper EFI files to point to the proper directory.

Make sure that you are on the proper drive before doing this, you can easily erase the wrong one. I have done this a couple of times in my life. I would never trust a windows disk manager nor a third party bcd repair disk to manage my linux directories.
I welcome others to chime in on this as I am limited in experience using Manjaro.

The following image is what I currently have on my EFI partition: i imgur com/j4Rmz3s.png
(under the EFI folder → Boot, Microsoft, and refind).

Anything I’d need to delete and is it safe to do so?

Luckily I don’t need to make a bootable with my phone, still had one laying around. Used gparted but got kind of clueless with the tool. I did adjust the bootorder and somehow it works, but I noticed some weird flags I didn’t set during the install (legacy_boot).

Screenshot: i imgur com/JyhQ0M0.png