Tras actualización 13 mayo 2024 no arranca manjaro gnome root clean

Buenas tardes:
Llevo usando manjaro gnome desde hace años y tras la actualización del 13 de mayo de 2024 no arranca, aunque lo he intentado varias veces con el kernel 5.15, que es el que uso y el 4.10, creo que este, que lo mantengo por si acaso aunque ya no tenga soporte, antes si arrancaba pero con esta última actualización no, queda una pantalla que solo pone:
root clean números/números números número files/número blocks
Si lo intento apagar y volver a iniciar encima pone una línea con journal1 recovery y debjao la línea de números que he descrito.
Es manjaro gnome en un intel core 2 con tarjeta gráfica ATI 64 bits y drivers libres.
He intentado desde un live en chroot reinstalar el kernel actualizar grub pero no resuelve el problema.
Me gustaría alguna indicación de que archivo os puedo mandar para estudiar el error o si a otros le ha pasado lo mismo con esta actualización y como lo ha arreglado.
Saludos y gracias.

1 Like

Cuando hayas arrancado y estén esas letras en pantalla, pulsa ALT y F3, a ver si te cambia a la consola de texto y puedes ingresar aunque sea ahí. Me parece que tu problema no es de grub/kernel, sino de la parte gráfica.

Buenos días:
Ahora estoy en el trabajo hasta por la tarde no puedo hacer nada, otros datos adicionales:

  • Ordenador comprado en 2011.
  • Desde agosto de 2011 hasta agosto 2013 empleé Windows 7, que aún tengo en otra partición pero que no uso, me sirve de almacén y tengo la partición montada en el arranque.
  • Desde finales de agosto de 2013 hasta que lanzaron Ubuntu 14.04 empleé ubuntu gnome primero 13.04 y luego 13.10, el día que salió ubuntu 14.04 puse manjaro gnome y no lo formateo desde entonces, aunque lógicamente si he cambiado el kernel.
  • Tengo el particionado tradicional con /dev/sda1 la partición pequeña que creó en su día windows 7, /dev/sda2 el propio windows 7 que lo tengo montado y me sirve de almacén, /dev/sda4 una partición lógica y dentro de ella /dev/sda5 /root 25GB, /dev/sda6 /home 25GB, /dev/sda7 swap 2GB tengo 4GB RAM 1TB de disco duro.
  • Gráfica ATI y los drivers libres.
  • Ahora gnome 46.1 con sesión predeteminada X11 e inicio automático en mi usuario.
    Si que debo decir también que antes le costaba arrancar pero arrancaba, un día hace no mucho no arrancó a la primera pero si al segundo intento y luego ya fue arrancando todos los días, por eso esta vez probé si ocurría lo mismo pero en este caso no funciona.
    Hace tiempo tardaba en arrancar y borré los archivos temporales de la ruta /usr/lib/tmpfiles.d/*
    ¿Podría haber algún archivo temporal viejo que impida arrancar?
    Con un live de debian 12 gnome, que lo tengo en un lápiz y lo puse con la herramienta ventoy, si puedo arrancar el equipo y el live funciona.
    Ayer desde el live en chroot con la herramienta mhwd-kernel primero desinstalé el kernel 5.15 traté de volverlo a instalar con mhwd-kernel -i linux515 pero como decía que faltaba el objeto instalé los dos paquetes que se habían desinstalado del kernel con pacman, actualicé grub con update-grub pero nada de esto resolvió el problema.
    Saludos y gracias.

Buenas tardes:
Pues si que parece que la última actualización da problemas con la gráfica, he mirado los errores del arranque -1 no he podido subirlos a la Web que me aconsejaron la otra vez porque me da error, parte de los errores son los siguientes
File /var/log/journal/e945672d862f45acb827e859f2c9c028/system.journal corrupted or uncleanly shut down, renaming and replacing.
kernel: intel_rng: Firmware space is locked read-only. If you can’t or
intel_rng: don’t want to disable this in firmware setup, and if
intel_rng: you are certain that your system has a functional
radeon 0000:01:00.0: Direct firmware load for radeon/CAICOS_pfp.bin failed with error -2
may 13 18:36:00 casa kernel: ni_cp: Failed to load firmware “radeon/CAICOS_pfp.bin”
kernel: [drm:evergreen_init [radeon]] ERROR Failed to load firmware!
radeon 0000:01:00.0: Fatal error during GPU init
radeon: probe of 0000:01:00.0 failed with error -2
r8169 0000:03:00.0: Direct firmware load for rtl_nic/rtl8168d-1.fw failed with error -2
may 13 18:36:11 casa kernel: r8169 0000:03:00.0: Unable to load firmware rtl_nic/rtl8168d-1.fw (-2)
/usr/lib/gdm-x-session[597]: ATI Radeon HD 4850 x2, ATI FirePro V8750 (FireGL),
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI FirePro V7760 (FireGL), ATI Mobility RADEON HD 4850,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility RADEON HD 4850 X2, ATI FirePro RV770,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: AMD FireStream 9270, AMD FireStream 9250, ATI FirePro V8700 (FireGL),
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility RADEON HD 4870, ATI Mobility RADEON M98,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI FirePro M7750, ATI M98, ATI Mobility Radeon HD 4650,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon RV730 (AGP), ATI Mobility Radeon HD 4670,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI FirePro M5750, ATI RV730XT [Radeon HD 4670], ATI RADEON E4600,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 4600 Series, ATI RV730 PRO [Radeon HD 4650],
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI FirePro V7750 (FireGL), ATI FirePro V5700 (FireGL),
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI FirePro V3750 (FireGL), ATI Mobility Radeon HD 4830,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility Radeon HD 4850, ATI FirePro M7740, ATI RV740,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 4770, ATI Radeon HD 4700 Series, ATI RV610,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 2400 XT, ATI Radeon HD 2400 Pro,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 2400 PRO AGP, ATI FireGL V4000, ATI Radeon HD 2350,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility Radeon HD 2400 XT, ATI Mobility Radeon HD 2400,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI RADEON E2400, ATI FireMV 2260, ATI RV670, ATI Radeon HD3870,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility Radeon HD 3850, ATI Radeon HD3850,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility Radeon HD 3850 X2, ATI Mobility Radeon HD 3870,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility Radeon HD 3870 X2, ATI Radeon HD3870 X2,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI FireGL V7700, ATI Radeon HD3690, AMD Firestream 9170,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 4550, ATI Radeon RV710, ATI Radeon HD 4350,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility Radeon 4300 Series, ATI Mobility Radeon 4500 Series,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI FirePro RG220, ATI Mobility Radeon 4330, ATI RV630,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility Radeon HD 2600, ATI Mobility Radeon HD 2600 XT,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 2600 XT AGP, ATI Radeon HD 2600 Pro AGP,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 2600 XT, ATI Radeon HD 2600 Pro, ATI Gemini RV630,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Gemini Mobility Radeon HD 2600 XT, ATI FireGL V5600,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI FireGL V3600, ATI Radeon HD 2600 LE,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility FireGL Graphics Processor, ATI Radeon HD 3470,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility Radeon HD 3430, ATI Mobility Radeon HD 3400 Series,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 3450, ATI Radeon HD 3430, ATI FirePro V3700,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI FireMV 2450, ATI Radeon HD 3600 Series, ATI Radeon HD 3650 AGP,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 3600 PRO, ATI Radeon HD 3600 XT,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility Radeon HD 3650, ATI Mobility Radeon HD 3670,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility FireGL V5700, ATI Mobility FireGL V5725,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 3200 Graphics, ATI Radeon 3100 Graphics,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 3300 Graphics, ATI Radeon 3000 Graphics, SUMO, SUMO2,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 4200, ATI Radeon 4100, ATI Mobility Radeon HD 4200,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility Radeon 4100, ATI Radeon HD 4290, ATI Radeon HD 4250,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: AMD Radeon HD 6310 Graphics, AMD Radeon HD 6250 Graphics,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: AMD Radeon HD 6300 Series Graphics,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: AMD Radeon HD 6200 Series Graphics, PALM, CYPRESS,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI FirePro (FireGL) Graphics Adapter, AMD Firestream 9370,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: AMD Firestream 9350, ATI Radeon HD 5800 Series,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 5900 Series, ATI Mobility Radeon HD 5800 Series,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,
may 13 18:36:28 casa /usr/lib/gdm-x-session[597]: ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon HD 5570,
El paquete xf86-video-ATI lo tengo instalado y lo he vuelto a instalar también he actualizado hoy el sistema ya que hay dos paquees de firmware, tengo kerenl 5.15.
¿Qué puedo hacer?
Saludos y gracias.

Buenos días:
Como otro de los problemas que sale en los logs es corrupción en un archivo de /var/log/journal ¿podría hacer # rm /var/log/journal/* en el entorno chroot? ya que antes de la actualización el arranque ya era lento y parece que según la wiki de archilinux si se pueden borrar estos archivos y eso acelera el arranque a algunos usuarios, aunque recomienda hacer una copia de seguridad. Con el mismo propósito ¿podría hacer # rm /usr/lib/tmpfiles.d/* en el entorno chroot?
Aún así
Aún así yo creo que tendré que esperar a ver si se actualizan linux-firmware que parece que hay actualización de este paquete ya en rama testing y mientras tanto seguir empleando un live de debian 12 en USB, por cierto lo tengo el live de debian puesto en una memoria USB con ventoy y es muy buena herramienta además el live de debian ya tiene los codecs por lo que puedo ver vídeos y usar el chroot muy buena herramienta ventoy.
Saludos.

Buenas tardes:
Parece que puede estar solucionado, con el live en chroot he hecho las siguientes cosas:

  • He vuelto a instalar linux 415 linux-firmware xf86-video-ati y actualizado el sistema pues ha habido dos paquetes actualizados.
  • He liberado espacio borrando los logs de /var/cache/journal mas viejos de 5 días.
  • He liberado espacio con pacman -Scc
    Hoy ha arrancado y mas rápido que antes.
    Saludos.

Buenos días
Pues el problema ya parece resuelto con lo que hice hoy he iniciado y realizado la nueva actualización sini problemas.