Transparency in OpenGL in KWin is blurred

I used default KWin setup with OpenGL compositing. I modified Konsole and panels with transparency. But the output was like nondeterministic. Sometimes there was no transparency at all and sometimes very crispy, rarely it made transparent effect but I was unable to find what corrected the behavior. Later I tried other Scale methods and other Rendering backend and Xrender finally gave desired effect. Any idea how to make OpenGL work in KWin

Display server: X Windows
GPU: Intel HD Intel(R) HD Graphics 4400
GPU driver: i915
Latency: Balance
Tear prevention: Automatic

Konsole with Gwenview in background
OpenGL (Doesn’t matter what options or version used)

Xrender (Scale method: Crisp)

Xrender doesn’t support blur (as on first image with OpenGL). If you don’t want blur effect with OpenGL in Konsole you need to go to Konsole’s profile settings and do as on image:

You can also disable blur globally in System Settings → Desktop Behavior → Desktop Effects

1 Like

Thanks, that solved the problem for Konsole.
And rest of the System

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.