Transparency Doesn't Work After Login (KDE)

It used to work fine, however, recently, (and I’m not sure what changed), transparency hasn’t been working at all from when I first log in and KDE starts. The most annoying part of this is that I use Terminology as my terminal application of choice, and it doesn’t display any borders at all without transparency for some reason.

If I pull up the compositor settings and change the “Rendering backend” from OpenGL 3.1 to OpenGL 2.0 and back again to 3.1, transparency works fine again until I reboot or just log out.

I’ve got an nVidia card with propriety driver version 440.1, if that matter at all.

Does anybody have any idea on what might be causing this, and what further information do you need from me, if any?

That seems to indicate something wrong with your drivers …
Or possibly KDE settings/user
(I guess you could check that one realy quick by adding a new test user)
Lets also look at:

mhwd -li
pacman -Qs nvidia
1 Like

mhwd -li:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-440xx            2019.10.25               false            PCI

Warning: No installed USB configs!

pacman -Qs nvidia:

local/lib32-libvdpau 1.4-1
    Nvidia VDPAU library
local/lib32-nvidia-440xx-utils 440.100-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/linux-latest-nvidia-440xx 5.7-2 (linux-latest-extramodules)
    NVIDIA drivers for Linux (metapackage)
local/linux54-nvidia-440xx 440.100-14 (linux54-extramodules)
    NVIDIA drivers for linux.
local/linux57-nvidia-440xx 440.100-15 (linux57-extramodules)
    NVIDIA drivers for linux.
local/mhwd-nvidia-340xx 340.108-1
    MHWD module-ids for nvidia 340.108
local/mhwd-nvidia-390xx 390.132-1
    MHWD module-ids for nvidia 390.132
local/mhwd-nvidia-418xx 418.113-1
    MHWD module-ids for nvidia-418xx 418.113
local/mhwd-nvidia-430xx 430.64-1.0
    MHWD module-ids for nvidia-430xx 430.64
local/mhwd-nvidia-435xx 435.21-1.0
    MHWD module-ids for nvidia 435.21
local/mhwd-nvidia-440xx 440.100-1
    MHWD module-ids for nvidia 440.100
local/mhwd-nvidia-450xx 450.66-1
    MHWD module-ids for nvidia 450.66
local/nvidia-440xx-utils 440.100-1
    NVIDIA drivers utilities

Also, the test user thing’s a good idea. I’ll try that quick when I’ve got a chance.

Sure. Your nvidia stuff doesnt appear off so thats worth a shot.

I can confirm that the issue still persists with a new user. Any ideas on where I should look next?

Maybe look for anything weird in

ls /etc/X11/{mhwd,xorg.conf}.d/

I don’t really know what I’m looking for here, as I’m fairly new to the “desktop” side of Linux. Nothing in the directory looks “weird” to me, but, as I said, I probably wouldn’t know if it was weird.

Would it be useful if I posted the files?

Maybe obvious, but did you checked System Settings > Desktop Behavior > Desktop Effects > Translucency?

You can also set opacity in Window management > Window rules.

What files are present?

It’s System Settings > Workspace Behavior for me, but yes, I believe that’s one of the first things that I checked before figuring out that it would start working again by changing my compositor’s “Rendering backend” setting from and back to OpenGL 3.1.

Also, the lack of translucency is system wide, not specific to one application, so I doubt it’d be a Window Rule, however, I checked, just in case, and I can’t find anything that would lead me to believe it would disable transparency with any particular window.

Thanks for the ideas, though.

├── mhwd.d
│   ├── nvidia.conf
│   └── nvidia.conf.nvidia-xconfig-original
├── xinit
│   ├── xinitrc
│   ├── xinitrc.d
│   │   ├──
│   │   └──
│   └── xserverrc
└── xorg.conf.d
    ├── 00-keyboard.conf
    ├── 30-touchpad.conf
    └── 90-mhwd.conf -> /etc/X11/mhwd.d/nvidia.conf

4 directories, 9 files

What do we have in

cat /etc/X11/mhwd.d/nvidia.conf
cat /etc/X11/mhwd.d/nvidia.conf.nvidia-xconfig-original


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.82

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
        Option "NoLogo" "1"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"

Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"


I’m sorry - it looks like some of the output is skipped … or is the ‘original’ file empty ?

My apologies. I edited the post for clarity. Yes, it is empty.

First lets do the update thing to be super sure:

sudo pacman-mirrors -f && sudo pacman -Syyu

(if everything is up to date you will get ‘nothing to do’)

We can also force reinstall the driver:

sudo mhwd -f -i pci video-nvidia-440xx

After that reboot and check.

I got “nothing to do” when updating, (as I had just updated things earlier today).

As for reinstalling the driver, I get this output:

> Removing video-nvidia-440xx...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia-440xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux57-nvidia-440xx breaks dependency 'linux57-nvidia-440xx' required by linux-latest-nvidia-440xx
Error: pacman failed!
Error: script failed!

I may know what that means, but I’m not entirely sure, and you could probably tell me faster than I’d be able to figure it out, right?

I’d have to remove the linux-latest-nvidia-440xx package, first, right? I forget what I needed it for, exactly, so I’m not sure if it’ll break anything. (I’m not really sure how it’s different from the linux57-nvidia-440xx package either.)

is just an umbrella package to try and keep you on latest kernel with driver 440.
You can remove it first (or keep it gone if you dont want it).

I’ve successfully reinstalled the driver and rebooted my system. It doesn’t seem to have changed anything, (including not resolving the issue).