Tracker-miner-fs-3 high cpu and won't stop

I’ve just switched to Manjaro and installed it on my new computer, and I have something really annoying.

tracker-miner-fs-3 is using a lot of cpu each time I press my Super key and search something, and when it does it keep going indefinitely while using between 13 et 40% of my cpu. Also prevent me from opening Nautilus.

I tried searching and doing multiple things like checking my LANG environment variable was set and it seems to be.
I also tried multiple ways to deactivate it like adding files like tracker-miner-fs-3.desktop and tracker-miner-fs.desktop in my /etc/xdg/autostart folder and putting in them X-GNOME-Autostart-enabled=false or also Hidden=true but nothings seems to work.
I also tried to deactivate from dconf editor but it did not work.

Even when I kill the process manually it came back as soon as I search for something.

I really want to stay on manjaro but this prevent me from working because it reduces performance and also block the Nautlius app. I hope and would really appreciate if someone can help me here.

Thanks !

Try disabling apps under Settings > Search and see which one might be causing the issue.

So i tried that and it turns out that it’s the Nautilus app that cause tracker to go crazy. When disabled everything seems fine.

I figured that’s because for my work I have a lot of projects with node_modules, so I added it in the ignored-directories-with-content in dconf editor at /org/freedesktop/tracker/mines/file but it don’t seem to help at all.

Any idea how I can fix this even more ?
But for now I can finally use Manjaro again so thanks a lot !