TPM and Secure Boot screwed things up

I have Manjaro installed on an SSD connected to an internal USB header. The reason why I use this setup is so that Windows cannot break my bootloader. I boot using the motherboard boot device selector. It has worked very well so far. Unfortunately I wanted to experiment with Windows 11. As a result I switched on secure Boot and TPM and now I no longer see all my drives in the device selector. It does see a UEFI partition on a USB device which looks like it will be my Linux install, but it wont boot from it. It just loops back to the selector. I have since switched off secure boot and also TPM but it seems to make no difference. So I have again re-enabled them. Is there any way I can rescue this Linux install?

I have learnt that I need a key and do something with grub but I have no idea how I go about this. I have also found that with both TPM and Secure Boot enabled I can no longer boot from anything but the Windows drive. Not even USB install drives.

Any help would be appreciated. I don’t even mind re-installing Manjaro as its not my main OS. But it would be nice If I can do this with TPM and secure boot enabled so I can also run Win 11.

I would rather try to install Win11 without it, have a look here:

Secure Boot can be used with Manjaro but it’s a hassle to set it up, check this:

If you want to use TPM, make familar with this:

Hey @thedatabug, Welcome to the forum.
Windows 11 needs both Secure boot and TMP enabled for working. I have been using Windows 10 and Manjaro with Dual Boot with SB enabled.
You will need to install sbupdate, efitools for working with secure boot.
To enable Secure boot in Manjaro you can read this article: here.
At last when Everything is done, run these two commands:

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --modules="normal test efi_gop efi_uga search echo linux all_video gfxmenu gfxterm_background gfxterm_menu gfxterm loadenv configfile tpm" --disable-shim-lock
sudo sbupdate

However, this is not an easy process, and try this only if you are fully aware of what you are doing.
PS: You can try @Wollie Idea, it is easy.

@ [garvitjoshi9]
Thank you for reply. I have looked through that link and oh wow it lost me in the first few paragraphs.

@ [Wollie]
Thank you for the link regards installing Windows 11 without TPM or Secure Boot. My only worry is that when Windows 11 releases that these workarounds might stop working or get disabled by Microsoft.

I guess I will disable TPM and Secure Boot.

One more question. I have so far tried to boot Manjaro by switching off Secure Boot and TPM but this doesn’t seem to be working. Is there some way I can make my Manjaro install accessible again?