Tplink ac1200 high gain wireless dual band usb adapter, model no.archer t4uh

how do i make it work on manjaro kernel 5.9.11-3. I’ve tried numerous methods but havent had much success.

  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=d2ea02b4-8fc9-4e29-8640-9b661120497f rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 0604 date: 07/02/2019 
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701011 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86268 
  Speed: 4187 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 4190 2: 2096 3: 2196 4: 2193 5: 2096 6: 2195 7: 2196 8: 2196 9: 4191 
  10: 2095 11: 2096 12: 2195 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  always-on, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: Gigabyte driver: nouveau 
  v: kernel bus ID: 08:00.0 chip ID: 10de:1f82 
  Display: x11 server: XOrg 1.20.10 compositor: kwin_x11 
  driver: modesetting,nouveau alternate: fbdev,nv,vesa display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: HDMI-1 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") 
  diag: 604mm (23.8") 
  OpenGL: renderer: NV167 v: 4.3 Mesa 20.2.3 direct render: Yes 
  Device-1: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel 
  bus ID: 08:00.1 chip ID: 10de:10fa 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0a:00.4 chip ID: 1022:1487 
  Device-3: C-Media USB Audio Device type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 5-3.1:4 chip ID: 0d8c:0012 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel bus ID: 03:00.0 
  chip ID: 8086:2526 
  IF: wlp3s0 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI modules: r8169 port: f000 
  bus ID: 04:00.0 chip ID: 10ec:8168 
  IF: enp4s0 state: down mac: <filter> 
  Device-3: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
  bus ID: 3-5:2 chip ID: 8087:0025 
  Device-4: Ralink RT2070 Wireless Adapter type: USB driver: rt2800usb 
  bus ID: 5-3.2:6 chip ID: 148f:2070 serial: <filter> 
  IF: wlp10s0f3u3u2 state: up mac: <filter> 
  Device-5: TP-Link Archer T4UH wireless Realtek 8812AU type: USB 
  driver: usb-network bus ID: 5-4:3 chip ID: 2357:0103 serial: <filter>

mod. edited for reasons of better readability

Welcome to the forum! :wave:

Please post your system info as outlined here:

alright done

You need this one:
You can get it from Pamac, with AUR enabled.

So knowing what package i have to install with out internet how do i install it on that pc
i tried git clone and then makepkg -si in from that computer but it threw me this error